I have a

MSI GT72S 6QD(Dominator G), I tried updating the flash and now it won't boot. Black screen. I have files on 3 hard drives. PCIe, 2 SSD RAID 850 evo SATA III's, and 7200 HDD. Is the raid array destroyed now? Is it possible to take the 2 raid HD's out and connect them to another computer?

Just as an update to anyone else whose bios gets a bad flash and starts panicking, the raid was NOT destroyed and plugged right back into a new motherboard and bios and windows immediately recognized ALL FOUR hard drives(even the non factory dual raid) and all files. Didn't even have to boot into the bios to change any settings. As easy as can be. As Hennes said below the data for the raid is written on the SSD themselves and were auto recognized regardless of the order put in. How HAPPY.

  • Disconnect ac power, remove main battery and cmos battery for 15 minutes, re-insert cmos battery and ac only, see if it recovers.
    – Moab
    Aug 7, 2016 at 20:34
  • I've read other users with exact same set up and that didn't work. CMOS will just reset the setting, but the bad flash that I did still broke the bios code right? or will the cmos reset the patch that I did? Aug 7, 2016 at 20:38
  • Do you know where the cmos jumper is on my laptop. I can't find it Aug 7, 2016 at 20:54
  • Clear CMOS erases settings. Flashing the firmware writes to a place which does not need any power and which is not erased by clearing CMOS. (Which is a good thing since you would not be able to boot or flash without any firmware if it was completely wiped. You need at least a working minimal setup to update/recover.
    – Hennes
    Aug 7, 2016 at 20:59

1 Answer 1


Lets break this down into two parts.

First of all a generic part:

You have a motherboard and tried to update its firmware to the newest EFI/BIOS. That can go wrong. That can also mess up your settings which is why many firmware upgrade tell you to '1. Write down current settings. 2. Flash the new firmware. 3. select "use defaults" and 4. Adjust whatever whatever you want".

Secondly you write Black screen. I read that as 'the system does not even POST`. That means it does not even get to the harddrives. Worrying about their state is premature. If you feel safer feel free to completely remove then from the desktop, so you can focus on the main problem. And as I see that it is an 'I updated the motherboard firmware and now it does not POST'. Check SU for related posts. Most will mention possible RO backup firmware or recovery EFI updates.

Thirdly, your data: You have data on four drives. The data is still there and you can just move the drives to another working computer. No data is lost.

Is there raid array destroyed now?

It depends on the array. If the RAID array was software RAID you can just connect them to another PC and use them there after installing the same software. If it used hardware RAID then you need to move over your HW RAID card. *1. If you used intel fake RAID then you should be able to move them over to a new system and install the drivers just as with normal software RAID, though you might need a similar motherboard.*2

Is it possible to take the 2 RAID HD's out and connect them to another computer?

Yes. Assuming you did not encrypt them and you should be able to use them.

*1 Assuming not, since that usually need an expensive dedicated card and you did not mention one. HW RAID is rarely found on non-workstation motherboard.

*2Which makes this the worst combination between HW and SW RAID.

  • This is a laptop with Samsung 850 EVO M.2 SATA III so from what you're saying it must be software raid (it's plugged into the small 4 slot M.2 laptop card. Will I BREAK the raid array if I disconnect the hard drives and don't put them back in the same order or have the exact same settings after I get my laptop back from MSI? Aug 7, 2016 at 21:37
  • I read someone else who did this and they plugged the raid back in and it said non raid in the bios and they said it was broken. Aug 7, 2016 at 21:38
  • Great! I hope you are right. The RMA said I can send the laptop without the hard drives in it, so I will find out when the laptop gets back if factory resetting the bios affected the raid. Aug 7, 2016 at 21:48
  • I have no experience with this laptop. But I do have experience with md0 (linux software RAID) and a few hardware RAID cards. None of those care about the order you connect the drives with. Information written on the drive indentifies it clearly enough for the array to work even if you switch them around.
    – Hennes
    Aug 7, 2016 at 22:34
  • I see about 5 or 6 different words to identify the connection types for a usb to m.2 port. Do you know which one will connect to the 4 port m.2 PCIe NVMe so I could connect and see if samsung magician recognizes it? I see ngff, socket 3, m-keyed b+m keyed, and lots of other words that are gibberish to me. Do you know which one will work with a samsung evo m.2 850 and a 128gb NVMe? THEY ARE ALL 3 plugged into one 4 port adapter. Aug 7, 2016 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.