4

My monitor is a Dell P2715Q, and it does support DDC/CI (presumably). It's connected to my computer with a DisplayPort, and I'm trying to change the brightness from my computer, but it neither works on Windows nor Ubuntu.

I'm using Intel HD 530 integrated graphics, and supposedly, the drivers should support DDC/CI over DisplayPort. The "DDC/CI" option in the monitor's OSD is set to "enabled".

When I try to change the brightness on either Windows or Ubuntu, there is no option to do so where it would normally be. On Linux, I'm also testing with a program called ddccontrol, and when I run ddccontrol -p, it says: "No monitor supporting DDC/CI available".

1 Answer 1

6

On Linux, the first order answer is that it should just work. The I2C signals are carried over the DisplayPort AUX channel, and the video driver should make this transparent.

ddccontrol can be problematic because, as normally built (there's a lot of #iftested code) it bypasses the public i2c-dev interface and attempts to control the I2C signals directly.

I suggest you try my more recent ddcutil.
There are lots of features, but the following should get you started:

# To display detected monitors:
ddcutil detect 

# To get the current brightness value (assuming just 1 monitor):
ddcutil getvcp 10

# To set the brightness to an example value of 50:
ddcutil setvcp 10 50

That said, I can't speak to the HD 530 specifically. If it uses the standard Linux i915 driver then it should work.

5
  • I'm using an Nvidia card now and it's still not detecting for some reason. I tried a couple cables too. Not sure what the issue is.
    – Hassan
    Feb 15, 2017 at 16:39
  • @hassan Without more detail, I can't really say why things aren't working. However, newer Nvidia cards generally need some special settings for I2C communication to work properly. See [here] (ddcutil.com/nvidia) If you're using ddcutil, command "ddcutil environment" performs a collection of diagnostic checks. Feb 16, 2017 at 19:48
  • I think it might be a problem with DisplayPort. I'm running a pair of ASUS VC239 displays, "ddcutil detect" says DDC supported, but DDC communication failed. I switched today to a new hardware, which included moving from an old nvidia DVI dualport card to an nvidia Quadro M620 Mobile 4-port DisplayPort card. ddccontrol worked fine before moving to DisplayPort, so I think it's possible that there's a problem in the communication between the card and the displays, even though DVI and DisplayPort are presumed identical on protocol level. I can provide some more debug output if interested.
    – frank42
    Oct 25, 2018 at 15:00
  • @frank42 I drafted a detailed response to your comments which StackExchange rejected as too long, so instead I'll just suggest that you run "sudo ddcutil interrogate 2>&1" and post the output as an attachment at the ddcutil issues page which I use for general support. Oct 29, 2018 at 8:03
  • Sorry I did read your comment just now, @SanfordRockowitz, but I recently found the problem with my card. According to ddcutil.com/nvidia there was a specific option string to be set in xorg.conf which fixed the error. I honestly don't know why it took me so long to find that page, but the solution works fine and ddcutil does perfectly its job now...
    – frank42
    Nov 19, 2018 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.