0

The Problem:

I am trying to remove my installation of Fedora 23 from my Acer Aspire 5750 (note: the laptop model is too old to use UEFI) and reinstall Windows 7. I have been using Fedora 23 for a while but I now need Windows back for a list of reasons.

I have made and remade this USB possibly 20 times now with every type of partition from Fat32 to NTFS and in-between. I have followed 5 different blog posts on how to make a bootable Windows USB stick in Fedora. I have the boot flag set to on. I have used the native Fedora Live USB program to burn the Windows ISO to the USB (no I did not just copy the files over) and I have also used UNetBootin and Disks Writer program that comes with Fedora. I have tried so many combos and for some reason I get the same results... always. Something happens and it skips over the USB completely (so it seems, no prompts or any indication of the USB loading) and goes right back to GRUB list to choose my Fedora installation. No matter what I do I cannot get it to start into the usual Windows Installation loading prompts.

I have set the boot priority/order sooo many times, to use the USB-HDD Sandisk Cruzer Edge and I have looked through every nook and cranny of the BIOS options, believe me, there is nothing to do with Legacy, CSM (or regular mode) or UEFI. It's all very straight forward.

I used to reinstall my Windows 7 OS every 4 month or so in the past on this laptop so I know it all works. The only thing that has changed is that I now am running Fedora instead.

Summation:

  • No UEFI in laptop
  • Fedora 23 installed, want Windows 7
  • Tried with Fat32 and NTFS
  • Bootable USB has ISO burned to it, not files copied over
  • Boot flag set to on
  • Properly set the boot order in BIOS and the name showing uses words HDD
1

Look for efifolder on USB root. If you find a bootmgr file on there as well you can remove efi folder and try booting after that. The reason this happens is because windows images starting with 7 have efi boot sector for both MBR and GPT so whether you like it or not the USB ends up being bootable only in UEFI. If the above doesn't work then save some time and try a DVD instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.