3

I faced this problem at this morning, while I was trying to start developing (working), but vagrant up did not agree with me.

The virtual machine (I use Scotch-box -box) simply did not start. Also the Virtual Box -application did not start at all. Not even for a blink or to show a error message.

How to fix this?!

6

Background: Windows 10 is now 1 year old and released so called anniversary update last week. Among many updates, it also broke up things like forced cs:go fps to 30(?) and ofc - virtual box and vagrant too.

I've read that someone had these problems too, but fixed it by disabling Hyper-V. This however was not my case, since I didn't have the thing even enabled.

Solution:

  1. Update vagrant if you don't have the latest version installed.
  2. Update Oracle Virtual Box
  3. Restart your machine
  4. Vagrant up
  5. Boom - done.

Why: For some reason, the previous Virtual Box version vas not compatible with the new Windows 10 update. Even with different compatibility modes. It didn't even show errors when I tried to launch it. I first tried to only update it without updating Vagrant, but then when I tried to run vagrant up again, it forced me to downgrade the Virtual Box, so I was back to square one, eh?

Luckily this time the process to get things back on, was relatively simply.

Hope someone finds this helpfull!

1
  • Thanks, I too had to uninstall virtualbox and then install the latest version of Vagrant. – Maria Ines Parnisari Sep 19 '16 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.