2

Since last week my Windows 10 refuses to delete folders, regardless of the location. When I shift-delete a folder (or multiple folders), it disappears but after refreshing the folder it's there again. This even occurs when using rmdir through the commandline and when using cut/paste to move the folder.

When I then try to access that 'deleted' folder I get an 'Access denied' error. I then have to restart explorer.exe for the folders to completely disappear.

After a reboot this problem still persists. When deleting to Recycle Bin this issue does not occur.

Anyone ever experiences this odd behaviour & have a fix for it? I don't want to have to restart explorer.exe everytime I delete a folder.

  • Please go through this it might help you : fixedbyvonnie.com/2014/01/… – SolveProblem Aug 8 '16 at 8:27
  • Thanks but I already tried that... I can't even take ownership of the reappeared folder, it looks like a ghost folder. – Kev Aug 8 '16 at 9:20
4

Running a Process Monitor trace might help find what's happening when you try to delete that folder.

  1. Download and run Process Monitor.

  2. Press Ctrl + L to access the filter dialog.

  3. Configure the filter as in this image:

enter image description here
(Replace foldername with the actual folder name.)

  1. Click OK. ProcMon would start capturing events.

  2. Ctrl + X to clear the existing events.

  3. Open File Explorer and delete the folder (which you said is reappearing automatically.)

  4. Wait until the deleted folder reappears. Once it does, immediately switch to Procmon window, and stop capturing events by pressing Ctrl + E.

  5. Folder creation/deletion events would be listed there along with the Results of each event. You can see which process is recreating the folder, or if the folder was successfully deleted or not, in the first place.

  6. If you can't make anything from the log, save the log to a .PML file with All Events selected.

  7. Zip the file and upload to your cloud storage account like OneDrive, Dropbox etc. Compressing the file reduces the PML log size by 90%. Share us the link to the log file.

  • Process Monitor doesn't seem to start on my system. Process Explorer from SysInternals works so I don't know what the problem is. I get the screen with the License Terms & I click agree but then nothing. Not even in Processes. Will try further, thanks for the reply. – Kev Aug 8 '16 at 9:54
0

I think I found the culprit. There was an app installed that synced my files to a cloud storage provider. That app was using SharpShell, which is some kind of extension for .NET applications to control the context menu.

After I uninstalled that application the shift-delete function returned to normal without the folders reappearing. I suspect the SharpShell extension was interfering with the normal operation of my Windows Explorer.

0

I tried every single suggested solution and none of them worked. Finally, I found that my antivirus quarantine contains files that were previously in these reappearing folders. Every time the antivirus has its virus definitions updated, it recreates these folders again! I cleaned the quarantine, hence the disappearance of these folders forever.

-1

Interesting find but not a surprise. Origin.exe (game manager) was recreating the folder. I uninstalled ME2 (Mass Effect 2) game via Windows add/remove initially. I still had the Origin game manager open. Once I stopped the origin.exe process the ME2 folder finally disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.