8

Or another similar program? All I want to do is record the sounds coming from say firefox, or any other app, for use as samples in music. I need to do this in both windows and linux (ubuntu 9.10).

I have looked through the preferences of audacity but didn't find anything that let me select the system sound. Perhaps I overlooked it, because I was able to do this with earlier versions of audacity.

7

In Windows Vista, I had to do the following:

  1. Go to Control Panel > Sound > Manage Audio Devices
  2. Select the Recording tab
  3. Right click an item or blank area on the list of devices and enable "Show Disabled Devices". This made the Stereo Mix device appear.
  4. Right click the Stereo Mix device and select "Enable"

"Stereo Mix" was then available as an input device for Audacity.

  • 1
    For me, recording devices doesn't list 'Stereo mix' :( – Colonel Panic Sep 22 '12 at 16:14
  • @ColonelPanic - Was missing for me too (even disabled/disconnected), but I found a thread where users reported downgrading their RealTek driver to make it reappear. Search Google for version 6.0.1.5322. If Windows keeps saying you have the latest driver, see this thread. In "Have disk...", select the "HDX.inf" file, which for me was under "Vista64" in the driver package I downloaded from CNET. – Andrew Cheong Aug 28 '13 at 17:27
  • Seems Windows 10 no longer has this :/ – Supuhstar Nov 21 '17 at 3:01
  • 1
    @Supuhstar Over a year late, but see my answer below. – kojow7 Feb 5 at 18:45
2

Windows and Linux

In the drop-down menu on Audacity's mixer toolbar, choose “Wave Out” or “Stereo Mix” as the input source. (The exact name may be different, depending on your computer's sound drivers.) When you press the Record button, Audacity will capture whatever sound is playing on your computer's speakers.

Source

enter image description here

  • There is no "wave out" or "stereo mix" in that dropdown box on the mixer toolbar. The is nothing that resembles what you said. I would try posting a screenshot, but for some reason I can't do that when audacity has focus. – Alex Feb 20 '10 at 8:37
  • @Alex - did you select your sound card as recording device in Edit > Preferences > Audio I/O? – Molly7244 Feb 20 '10 at 12:52
1

There are a few ways to do this with Audacity (on Windows), but here are a couple of options:

Best quality:

  1. In the first drop down menu (Audio Host) change the default setting from MME to Windows WASAPI.

  2. In the second drop down menu (Recording Device) change the default setting from microphone to your output device (usually your speakers or headphones).

You will now be able to record whatever audio plays on your computer without picking up any distortion from your mic. Keep in mind if you have any sound alerts (such as message alert sounds etc.) it will pick up those as well.

Not as good quality, but better than mic/cable:

For those that cannot find Stereo Mix option in Audacity, it is likely because it is disabled by default in newer versions of Windows. You first need to enable it in Windows as follows:

  1. Right-click the audio icon in your system tray (lower-right corner of Windows)
  2. Select recording devices
  3. If you see Stereo Mix and it is disabled, right-click on it to enable it.
  4. If Audacity is currently open, close and re-open it so that it detects the new recording device.
  5. In Audacity, you can now select Stereo Mix from the second drop down menu (Recording device)
0

On ubuntu with Pulseaudio you can route output to whatever you like, check this guide. On windows (at least on xp, don't know wista or 7) you should have a "Stereo Mix" under Recording Devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.