11

Firefox 50's release notes:

Emoji for everyone! Firefox will use built-in Emoji on operating systems without native Emoji fonts (Windows 8.0 and lower and Linux)

So I'm on Windows 7 and I absolutely dislike colored emoji for how much distracting they are. There is no font file called "EmojiOne Mozilla" to delete from Windows' fonts folder, unfortunately. And there is no relevant option in about:config list I could find.

How do I disable colored emoticons?

  • It's only a "test" release. Who knows what will change when it is properly released. – DavidPostill Aug 9 '16 at 11:30
  • bugzilla.mozilla.org/show_bug.cgi?id=1231701#c135 "You could manually delete the font file in the Firefox directory." – Bob Oct 17 '16 at 5:11
  • 2
    Thanks for asking this. I prefer my emoji in the same color as the other text around it. – souser12345 Nov 21 '16 at 17:28
  • I am guessing the OP asked this from the point of view of a user, but as an add-on developer, I find this disappointing that I can't programmatically disable emoji on my own page, or modify the behavior so that the font color is overridden by CSS rules. Instead, now I have to go muck in a TTF file with FontForge, extract the vector data as SVG, create my own icons and font file, delete all unused, and inject my custom font on every page with CSS. But to consistently support legacy browsers back to v29, I guess I'll need to do that anyways. Thanks for asking the question and the responses. – user314159 Mar 3 '17 at 13:58
  • @user314159 I tried writing a script that removes all symbols in the unicode emoji ranges (via greasemonkey) but that didn't work for some reason. You could try that approach and share your progress if it works out. – user1306322 Mar 7 '17 at 5:53
5

It's not installed as a system font. The font file is contained within the Firefox directory, and deleting that one is sufficient. Note that you'll need to actually delete or move the file - simply renaming it, even changing the file extension, is not enough to prevent its use.

In the current Aurora build, the file you'll want to remove is <firefox>\fonts\EmojiOneMozilla.ttf, where <firefox> is the installation folder, which will vary depending on the bit-ness (Program Files or Program Files (x86)) and channel (Mozilla Firefox, Aurora or Nightly). On Windows you can right-click Firefox shortcut and select Open file location.

See also: https://bugzilla.mozilla.org/show_bug.cgi?id=1231701#c135

  • I deleted EmojiOneMozilla.ttf, emojis aren't disabled. – user598527 Dec 22 '16 at 17:51
  • 3
    @user598527 This doesn't disable emoji characters. It just removes the new bundled coloured font so the browser falls back to the system font. – Bob Dec 22 '16 at 21:46
1

Go to about:config, context menu (right click) > new > string. Set font.name-list.serif.x-unicode as preference name and Segoe UI Symbol as string value.
Colored emojis are instantaneously disabled, no need to refresh open tabs or restart the browser.

Source

  • 1
    You can even create an empty font with all emoji ranges and set it to that! – user1306322 Mar 8 '17 at 12:06
  • @user1306322: Do you mean that emojis can be completely disabled? Feel free to edit my answer. – user598527 Mar 8 '17 at 15:10
  • 1
    I used a font editor and opened up the EmojiOneMozilla.ttf, found the symbol used for unmapped/unknown characters and pasted it into every character in the font. It's crude because some of those are used in composite emojis like overlaying eyes, noses, hair and whatever over the base face shape, but it still works, and now every emoji symbol is a square. You could use a zero-width space character also, if you don't like seeing squares take up text space, but I'm comfortable like this. – user1306322 Mar 9 '17 at 5:56
1

This is what I ended up doing for myself: I took the EmojiOneMozilla.ttf font file from <Firefox installation folder>\browser\fonts\ and edited all its emoji symbols to contain the "not defined" symbol at the very end of the Unicode range.

Using FontForge editor, I copied it and pasted over all the emoji symbols (edit > select > glyphs worth outputting), and installed it as a system font, and gave it a unique name so it could be used in Firefox as a custom installed font (as described in the other answer here) and now every emoji symbol is a square.

You could use an empty space symbol instead if you want, but then you won't be able to see where an emoji is expected to be, and it might be a bit confusing.

  • I also tried this with Fontforge (October 2016 release) on Windows. How long did it take for you to process? The program hanged and appeared to be frozen when attempting pasting my custom image over all fonts. – user598527 May 21 '17 at 18:43
  • Could you upload your EmojiOneMozilla.ttf to a file hosting service? :) – user598527 May 21 '17 at 18:48
  • 1
    @user598527 I'm sure I screwed up something in it, so I'd rather everyone make their own roughly following the instructions I described. And if the font file is gonna be updated, it's better if people modify the latest versions that they have on their computer. Especially if there are any OS-specific differences which I might not be aware about. – user1306322 May 22 '17 at 4:04
0

Something broke with the method I've been using until today, so I looked up a new solution and this addon seems to be working: https://addons.mozilla.org/en-US/firefox/addon/no-emoji/

0

Removing the font file is one option. Found it here on Ubuntu Linux:

/usr/lib/firefox/fonts/EmojiOneMozilla.ttf
  • @fixer1234 Sure it does, by removing the font that provides the coloured glyphs. This is effectively the Linux version of my answer. (While the question is tagged Windows, the quoted release notes mention Linux in the same sentence. I suppose this could be split into a separate question.) – Bob Jul 10 '18 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.