Specs: Intel Pentium III @ 933 MHz, 512MB`PC133 SDRAM, 128MB GeForce FX5200, Maxtor 20.5GB IDE HDD, Ubuntu 9.10

Hi all, so I just installed Ubuntu 9.10 (from CD) on this machine after trying out Xubuntu. So, I did what I usually did, and blacklisted a certain driver to make my wireless adapter work. After a restart, I went to the Update Manager to get all the updates and it finds 227 update packages.

So the first time I was installing updates, the screen turned off, due to power management settings and I was AFK while it was installing updates. Upon arriving home, I try moving my mouse, typing in the keyboard with no response. So I forced it to shut down and restarted. I get a message and essentially I can't boot Ubuntu anymore.

So, I reinstall Ubuntu 9.10, following the same procedure as before, except that on first startup, I changed settings to keep my screen on. While doing software installation after updates were downloaded, Ubuntu eventually froze, while installing gcalctool. Mouse and keyboard were irresponsive, and I had no clue what was wrong. After a force reboot, I get the same message.

Why is Ubuntu freezing on me during updates installation?

Edit 1: I think that I may not be getting my wireless adapter to work properly, causing my machine to freeze. What I usually do it connect the adapter to USB after first startup, go to Terminal and type sudo gedit /etc/modprobe.d/blacklist.conf, add blacklist rt2800usb to the end, save, and restart. Wireless works upon restart... however, I think there is a more proper way to do it. Seems like this is the official way to get the wireless adapter running, will update.

Edit 2: So I have set up my wireless adapter differently this time, using Ralink's driver (rt2870sta) rather than a community-written driver (rt2800usb). Once again, I will try to download the important security updates ONLY.

Edit 3: Important security updates successfully downloaded and installed. Now, where do I go from here? Install all recommended updates?

Thanks in advance.

  • @Wesley: the new title may reflect the current problem but it really doesn't match the description of your post. i'm going to set the title back to the original; please post a new question asking about the proper way to configure the wireless adapter. you're welcome to link back to this question to give people context. – quack quixote Feb 21 '10 at 20:52
  • re: edit3 -- at this point i'd unselect all the recommended updates and install a few at a time. (like, select 1 or 2 packages; update mgr will autoselect their dependencies. install the updates. select 1 or 2 more. install. lather, rinse, repeat.) wasn't it the Nvidia driver update that seemed to be crashing? leave that for last. – quack quixote Feb 22 '10 at 7:11
  • Alright. Will do. And yes, when I tried to activate the NVIDIA driver prior to installing the recommended updates and it froze. Would you think that the nvidia-settings update would allow me to activate the NVIDIA driver without freezing in the process? – Wesley Feb 22 '10 at 17:55
  • Okay all updates have been successfully installed, including nvidia common. Now, which hardware driver should I activate? – Wesley Feb 23 '10 at 1:34
  • I have the option of: (1) NVIDIA accelerated graphics driver (version 173) [Recommended] (2) NVIDIA accelerated graphics driver (version 96). Latest Windows driver for the FX5200 is version 175.19, but when I activated that first driver before installing recommended updates last time, it froze. WHat should I do? – Wesley Feb 23 '10 at 1:40

Do the freezes happen at other times as well or only during updates? System freezes can be caused by wonky drivers and bad hardware, and can be difficult to diagnose.

Consider booting to the console and running your updates from there.

  • Choose a "recovery mode" in the boot menu. If your system is giving you that boot error, see if there's an older kernel version in the boot menu and use that. (If you don't see the boot menu, hold down Shift after your BIOS screen to make the menu appear.)

  • When the system presents you with a recovery menu, choose the netroot option.

This gets you to a root prompt. Be careful; you're the superuser now.

  • Run aptitude update and let it finish. This updates the cache of available packages.

  • Run aptitude full-upgrade. This will install all available package updates, so if your system freezes are due to the update itself, your system will freeze here. If not, your system should be completely updated once this finishes.

Now try rebooting.

If you get the same error at boot, choose an older kernel from the boot menu and run this in a terminal:

sudo update-initramfs -u

(source) (from bug #1 and bug #2)

If the system does freeze during your console session upgrade, try upgrading a few packages at a time. You can attempt this in the console (run the aptitude command by itself to get a console GUI; select a few packages to upgrade with +) or in Xwindows (by selecting only a few packages at a time in Update Manager). If the update complains about missing dependencies, go ahead and install those too.

  • I'm sure the hardware is fine. I've used Memtest+ and ran the hard drive test from the Ubuntu disc. Will try other options when the opportunity arises. – Wesley Feb 21 '10 at 2:03
  • Alright... only installing important security updates. Will install recommended updates if this works first... – Wesley Feb 21 '10 at 2:21
  • Important security updates successful. Restart also successful. Will try installing recommended updates now. – Wesley Feb 21 '10 at 2:32
  • @Wesley: i have a system that likes to freeze up under Ubuntu 9.04 for no apparent reason; mem & drive are both known good. i've dealt with linux freezes before that turned out to be buggy video drivers (or maybe buggy video hardware, or both). not my favorite task. good luck with it! – quack quixote Feb 21 '10 at 2:38
  • @~quack: Exactly my problem now. It froze while trying to install the NVIDIA hardware drivers. After a force reboot, I am trying your recovery mode suggestion. – Wesley Feb 21 '10 at 2:43

Well, impossible to diagnose, but this seems like a bug in Ubuntu.

Your best bet is probably to report it to Ubuntu as a bug, with the exact steps to reproduce (as above). Then there's a fair chance it will get fixed.

Also, you could try redirecting the output of the update to a file (if this is possible in Update Manager), so you get a log that tells you where exactly the system crashed. That will help fixing the bug.

Also, try to use the hint from the bug report you linked, to get the system to boot even after the problem occured. Then you can probably collect more logs from the system.

  • I'm new to Ubuntu, so how would I redirect the update output to a file? – Wesley Feb 20 '10 at 23:55
  • Sorry, I don't know Ubuntu's Update Manager. You could use apt-get: apt-get install then the list of packages to install. At the end append ` > /tmp/apt.out.txt` to get a log into a file. – sleske Feb 21 '10 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.