0

We connect to a SaaS website that uses Citrix XenApp 6.5. We are presented with a list of applications that run using Citrix Receiver. It was working fine on my PC until after I updated to the Windows 10 Anniversary update. Now, when I click on any of the available applications on the website, and open the ICA file, nothing happens. It is isolated to just this PC.

I have tried uninstalling Citrix using the Receiver Cleanup Utility and reinstalling the Citrix Receiver version 14.4.1000.16. and get the same result. I cannot go back using System Restore, because the restore point before the update isn't available anymore.

  • What browser? Try another one. Works fine for me in IE11, FF (after manually enabling the plugin again), Chrome for several XA65 sites. – StackzOfZtuff Aug 11 '16 at 6:10
  • Edge, Chrome, Mozilla. Tried under a different username on my Windows 10 PC and get the same results. I have even uninstalled using the Receiver Cleanup Utility and installed again... many times... – Rick Aug 11 '16 at 12:56
  • If you get the .ICA-file downloaded, then the browser's job is done. Do you get the .ICA-file? – StackzOfZtuff Aug 11 '16 at 13:43
  • Yes. I have tried opening manually, since it is always saved in my Download folder; nothing Happens. – Rick Aug 11 '16 at 14:00
  • I have tried activating the Citrix logs, but they don't seem to say anything – Rick Aug 11 '16 at 14:43
-1

Sorry for a late reply, but i have a fix for you. This covers your exact problem and any other programs that break after doing a Windows 10 "major OS update/upgrade".

Windows 10 Service packs/Upgrades (Anniversary, Creator, etc.,) are more or less OS Upgrades and they generate a Windows.old folder, move your Users and windows folder there, upgrade your OS and under normal circumstances are supposed to move back your Users folder and whatever it needs from the backed up Windows folder.

What happens is i believe your profile is in limbo or orphaned or something along those lines. Some of your data may actually be linked to the C:\windows.old\users folder as an example.

My fix: Create a new profile.

I had a home user bring her laptop in who could log into citrix until the recent upgrade came out last month. I made a new profile and citrix works correctly again. her documents and desktop were not moved back and were being linked to the C:\windows.old\users folder. My guess is her Appdata folder as well as her registry information was stored there also and while i'm sure there is a way to fix that, but creating a new profile was easier for me to do at the time.

Of course, you can also just back up your data and reload Windows 10 as well. If it happened to my computer, i would do that, because i wouldn't trust the OS at that point. However, creating a new profile is easier and if you have the time, you could probably research on why and how to fix the profile linking issue, if creating a new account/profile isn't an option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.