So yesterday I booted my laptop up and the external monitor I have it connected to just stayed black. At first, I thought the problem would go away when Ubuntu was loaded, but it didn't. I tried to reboot a few times, to no avail. Then I decided to give Windows 7 a try, and suddenly (at the login-screen), my external monitor turned on and worked like normal.

I have connected the monitor via DVI, and this only seems to work with Windows now. I don't even get a signal in my BIOS! Mind you, everything was working fine before that, and I didn't change a single thing.

I then tried to connect the monitor via VGA (from my DVI jack, which can output VGA using an adaptor), and it worked again. However, 1920x1200 using VGA looks like crap - black print on white background is basically illegible.

Do you have any ideas how to fix this peculiar problem? I only use windows for gaming, so it's no real help that it still works normally. Please also excuse any spelling mistakes, I am practically typing this blindly.

Edit: I only have one graphics card in my laptop, and I can't select anything related to that in my BIOS. In fact, I can pretty much do almost nothing there. My laptop is a Nexoc Osiris E703, graphics gard is a GeForce Go 7900 GTX. As I mentioned before, DVI output during booting and on Ubuntu was working fine for years before yesterday!


I've had similar issues before. In my case, it's a Lenovo T400 with switchable graphic cards, connected to the monitor via a dock. You can specify in the BIOS setting which card should be used as primary, but still you cannot see the BIOS settings on the screen when connected through DVI or HDMI - only while using VGA.

You need to provide you laptop's make, and whether you use any kind of dock, or just connect directly. Also, check your BIOS for any related settings. This, to the best of my knowledge has nothing to do with the type of OS you use. It may simply be that DVI requires the graphic card's driver to operate, and that is only loaded when the OS is up, and not prior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.