I created a simple task that will start the Linux subsystem, execute zsh and run it on my desktop. However I would like to create a shortcut for this specific task on my taskbar.

Reason for this is because I don't want Cmder to do that by default, I want two separate buttons - one for regular and other for Ubuntu Subsystem.

Any ideas of how to do that? I've tried "C:\Program Files\Cmder\Cmder.exe" /single /cmd {Bash:Ubuntu} but it gives error The syntax of the command is incorrect. and loads default Cmder task.

Here is how my task looks like task

3 Answers 3


Here are two options:

You can set cmder to show your tasks on the windows taskbar. In the settings check under Task bar > Add ComEmu tasks to taskbar and be sure to hit Update now!

If you still want to create the shortcut, this command seems to do the trick:

"C:\Program Files\Cmder\vendor\conemu-maximus5\ConEmu64.exe" -run {Task}

Use ConEmu64.exe or ConEmu.exe (accordingly) inside your vendor\conemu-maximus5 folder of your cmder installation.


The first option of previous answer, now changes to Settings - Tasks - Taskbar jump lists(checkbox) I guess? Because I don't see what he said, may be changed now; and then when you open the first shell, at right lower corner, click the green + sign, you will see your favorite task in the task list, at bottom.

When I use the second approach of @archemiro I see this error:

Unrecognized parameter:

Valid options:
/START <path>
/SINGLE <path>
/TASK <name>

Must have suffered some change during the updates of Cmder.

So I tried editing the shortcut path to be like C:\xxxx\Cmder.exe /TASK my_task and it worked. Remember that in my_task, no {} is included.



Cmder.exe switches are different than Conemu.exe switches the /TASK is a Cmder switch for some reason cmder.exe /TASK <task_name> throws incorrect command error for me but Conemu.exe -run {task_name} runs ok!

edit: add backticks format


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .