4

Is there any way to stop Windows 10 Pro from rebooting after installing updates? After the anniversary update, it seems I no longer have the ability to control this.

There is a group policy I have set, but my understanding is that this is now ignored.

I have processes that I run overnight, and I simply cannot have Microsoft dictate when to turn off my computer. There must be a way to stop the reboot.

7
  • You can set activity periods.
    – Ramhound
    Aug 10 '16 at 22:08
  • Sure, for a 10 or 12 hour window. What if my process takes longer than that to run? The activity window is useless when I need to run a process all day long.
    – Smack Jack
    Aug 10 '16 at 22:09
  • You can't, if you want more control, use WSUS
    – Ramhound
    Aug 10 '16 at 22:26
  • I can't use WSUS, I run Windows 10.
    – Smack Jack
    Aug 10 '16 at 22:38
  • I run Windows 10 and use WSUS? download.wsusoffline.net
    – Ramhound
    Aug 10 '16 at 23:22
2

You have few options you can do, you can either do as @cybernard said in his comment

You can set active hours for the reboot between 2 ranges,under settings, updates,update status, active hours. You can set it so microsoft can reboot only during 1 particular hour if you want to. Additional updates are only released 2nd tuesday of the month, unless its an emergency.

or you can defer upgrades in the advance options since you have the pro version of windows 10.

There is few other options that I have learned because you have Pro, as well as I do myself.

Right click your start button and select run and type

gpedit.msc

Navigate to Computer Configuration\Administrative Templates\Windows Components\Windows Update.

on the right hand side double click Configure automatic updates and set it to enabled. Then you can tell it what you want it to do. You can even edit the registry as well but I am not sure where nor do I recommend messing with the registry.

The other thing you can do, is set your connection as metered. If you tell windows your wifi or ethernet connection is metered, it won't download updates automatically.

3
  • I'm still at the mercy of Microsoft with both of those options. If I have a critical process to run, I can't be 100% sure it won't be killed. I'm not the one who gets to make the decision for my own computer.
    – Smack Jack
    Aug 11 '16 at 15:29
  • The part about not allowing the installation of the updates doesn't answer the question. We want to know how to disable the automatic reboot after installing the updates.
    – palswim
    Aug 19 '16 at 0:13
  • 1
    Please note that NoAutoRebootWithLoggedOnUsers is not sufficient. See superuser.com/a/1192401/129204 Mar 25 '17 at 23:18
0

It appears that normally Windows pops up a box giving an interactive user a few minutes to respond and delay the reboot.

I found that if I run a full screen video, I can get that box to stop appearing. Running VLC on a constant loop in full screen worked for at least one night.

Maybe Microsoft will change the rules again with the next update, or may be Windows will eventually force me off my computer anyway, but this worked for a while at least.

1
  • I have updated my answer with more options you can do.
    – Frostalf
    Aug 12 '16 at 6:40
0

I ran across this post and I am giving it a try. (Will have to wait for some more updates to be posted before I have first-hand experience.) Essentially, you disable the job that handles the reboot in Task Scheduler and drop a folder in its place so that it cannot be automatically recreated. Updates will still be installed automatically, but you will have control over when you reboot. http://winaero.com/blog/how-to-permanently-stop-windows-10-reboots-after-installing-updates/

  • In Task Scheduler, navigate to Task Scheduler Library \ Microsoft \ Windows \ UpdateOrchestrator. Find the task labeled "Reboot".
  • Temporary fix: Disable this task. Windows will enable it again after some time.
  • Permanent fix (?): Delete the "Reboot" task. Navigate to C:\Windows\System32\Tasks\Microsoft\Windows\UpdateOrchestrator. Take the file labeled "Reboot" and move it somewhere else. (You can drop it back later if you want to revert this "fix".) Make a new folder in its place called "Reboot". This will prevent Windows from recreating the task as a file and folder can't share the same name in the same location.

Alternatively, you can disable the Windows Update service, and just start it when you want to do a manual check for updates. This also breaks the Windows Store, though.

0

I was having the same issues with my Windows 10 Pro, also. Microsoft would push an update and around 2:00 to 3:00 AM my computer would restart and my previously running processes had been closed. So I went into the Local Group Policy Editor and changed some settings there and it stopped my computer from updating like it was. It has since to restart, so I do not believe that it is ignoring this setting change.

Here are the following steps that I took:

  1. Click on the Start button and search for "Edit group policy" and press Enter (Search results)

  2. Once open, go to: Computer Configuration > Administrative Templates > Windows Components > Windows Update

In that folder, you should see a list of settings (visual representation of GUI configuration here).

  1. Here are the changes I made to the following settings:

    a. Configure Automatic Updates - I do not think changes to this is necessary, but I selected Enabled and made a change anyway. As mentioned before, I was concerned about the computer rebooting, but I made sure that the "Configure automatic updating" was set to it's default, 3 - Auto download and notify for install anyhow.

    b. No auto-restart with logged on users for scheduled automatic updates installations - Here is the important one. I selected Enabled and have yet to have my Windows reboot my computer on me. The "Help" section describes exactly what I was looking for.

Hope this helps.

2
  • Please don’t post images of text.  They are hard to read for everyone, impossible to read for blind people, and impossible to search, copy and paste.  All the text in your answer should be posted as text. (You may also post screenshots of control panel windows and other configuration GUIs as a supplement to your text.)
    – Scott
    Apr 3 '18 at 2:18
  • Duly noted. I did, however, post all text answers in text. The pictures are 100% optional as they only provide an additional option for clarity purposes. Those images are configuration GUIs for supplemental purposes. I did make sure the steps via the written text on this page could be followed without looking at those pictures. I reworded the one sentence for clarity for that purpose. Thank you for your answer improvement suggestion.
    – zim7563
    Apr 4 '18 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.