4

We have some contractors who are remoting into a development server using Remote Desktop Connection (mstsc.exe). One or more of these contractors is reporting that when they remote in and run SQL Server Management Studio or Visual Studio, some of the fonts are messed up and it's interfering with their work.

I was able to reproduce this problem using a domain admin account.

Below are a couple of screenshots using mstsc, remoting into the development server on my regular domain account and then doing the same thing remoting in using the admin account.

Regular Account (fonts look okay): SSMS Signin dialog, logged in with regular account SSMS Stored Procedure list, logged in with regular account

Administrator Account (screwy fonts): SSMS Signin dialog, logged in with administrator account SSMS Stored Procedure list, logged in with administrator account

The server operating system is Windows Server 2008 R2 Standard Edition. It is up-to-date on all patches, updates, etc.

The client operating system, running Remote Desktop Connection, is Windows 10 Enterprise. It is also up-to-date on all updates.

Below is an image of the "Server Properties" dialog's "Advanced" tab when logged in with my admin account (it looks fine when viewing logged in with my regular domain account): Advanced Server Properties

I could sure use a hand resolving this issue!

Thanks!

25
  • What options are you and your contractors using for the RDP connections (Options>Experience)? Have you tried turning some or all of them off? I've never had a problem with using only Visual styles and Persistent bitmap caching selected. – B540Glenn Aug 23 '16 at 20:42
  • Which Windows versions for client and server? If you are using a .rdp file, please post it - I am principally interested in any options relating to the display. – harrymc Aug 24 '16 at 8:31
  • @B540Glenn - Not sure what options they're using, but in all instances when I connect (both as admin and normal account), options are as follows: Display: Full Screen – STLDev Aug 24 '16 at 15:38
  • @B540Glenn - one more time - Experience tab is set to "LAN (10Mbps or higher)" and the following are checked: "Font smoothing", "Visual styles", "Persistent bitmap caching", as well as "Reconnect if the connection is dropped" are all checked. I've also tried unchecking "Font smoothing" and "Visual styles" together and separately, no joy. For what it's worth, the display configuration is set as "Full Screen" and color depth is set to "Highest Quality (32 bit)". – STLDev Aug 24 '16 at 15:56
  • @harrymc - the server is WIndows Server 2008 R2, the client is WIndows 10 Enterprise Edition, it has the update "Update for Windows 10 Version 1511 for x64-based Systems (KB3149135)" applied. – STLDev Aug 24 '16 at 16:06
1

It's possible the issue isn't specific to Remote Desktop. The problem may be with the remote computer itself instead of Remote Desktop. Examples include corruption of font files or in the settings of the user profile.

To test for this, log on to the computer directly using the affected and non-affected accounts and observe the results. If the issue persists you've ruled out Remote Desktop as the cause.

Given some but not all of your user accounts are affected, you can narrow down the source of the problem by leveraging differences between the accounts in your testing. Try a new user profile. Try promoting the non-affected account to administrator status to determine if that's contributing to the symptoms.

You may find some clues by using Microsoft Process Monitor. From the product description page:

Process Monitor is an advanced monitoring tool for Windows that shows real-time file system, Registry and process/thread activity.

You can use Process Monitor's powerful filtering tools to find events that may be relevant to your problem. I suggest you start by excluding all events that return a result of SUCCESS as shown here:

enter image description here

While there will still be a lot of events that (legitimately) fail, you may very well find some action that fails in some manner that has to do with loading or manipulating fonts.

1
  • I'm now certain that it has nothing to do with a connection over RDP. I've tried a couple of things, such as having a new domain account created, as well as replicating a profile from the working account. I still don't understand why this is happening. – STLDev Aug 31 '16 at 19:44
0

The problem was not with remote connections of any type. Confirmed that the issue was noticed when logging directly into the server console.

I still have not found a real solution to this issue!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.