3

We have installed a TFS Build Agent on Windows 2012. In a post-build script we are packing a setup using WIX.

But we get the following error, when

light.exe : error LGHT0217: Error executing ICE action 'ICE01'. The most common cause of this kind of ICE failure is an incorrectly registered scripting engine. See http://wixtoolset.org/documentation/error217/ for details and how to solve this problem. The following string format was not expected by the external UI message logger: "The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. [...]"

This line (atleast very similar lines) is shown 8 times.

What we tried so far:

  1. We set the TFS Build User (DOMAIN\SA-TFS-Build) to local Administrator
  2. We used the msiexec.exe /unregister and msiexec /regserver
  3. We even started the Windows Installer Service manually and then ran the build.
  4. We rebooted the PC after all these steps.

But nothing has helped so far, everytime the same message.

What could be wrong? Does our TFS User not have the required rights, when being a local admin?

Thanks in advance!

-1

Adding the build account as a member of the local administrators on the build machine (followed by a reboot) helped get rid of the error for me.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.