25

I have a Windows 10 Home PC that is often unattended but doing important work. The work follows no particular schedule, and may take place at any time of day or night.

As things stand, Windows 10 (anniversary update) is configured to automatically restart and install updates during inactive times. The user can configure the inactive times, but the OS forces the user to have no more than 12 active hours a day. This means that the machine may well choose to restart at a time that is highly disruptive to our work and when there is no user around to prevent the restart.

For this reason, I would like to ensure that Windows never automatically restarts. How can I achieve this?

26

Here are the instructions to disable auto restarts for windows 10 Pro and Home editions. If you have a different version (education, enterprise) the process is different - update your question to that effect and I'll add that info.

There are two methods provided. The first is Pro only. Win 10 home doesn't have the group policy editor so it has to be configured via the registry. This registry method will work for both Pro and Home.

I confirmed that this works on the Anniversary update version (win 10 pro). There is one caveat - a user must be logged in for this approach to work.

Win 10 Pro:

  1. Press win+R then type gpedit.msc and press enter
  2. This will open the group policy editor. Browse through the 'tree' to the following entry: Computer Configuration > Administrative Templates > Windows Components > Windows Update.
  3. Look on the right panel and search for the option named No auto-restart with logged on users for scheduled automatic updates installations.
  4. Double-click on it, then change the radio button in the popup window that will appear from not configured to enabled and click OK.
  5. To make the system immediately apply the changes you just made, press WIN + R again and issue the gpupdate /force command

Win 10 Pro (alternative method) and Home:

  1. Press win+R; type regedit and press enter.
  2. Browse to the following registry entry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
  3. If you do not have a WindowsUpdate and/or AU entry, you need to create them. Follow the 'source' link below for add'l info on how to do this.
  4. Inside the AU key, create a new 32-bit DWORD called NoAutoRebootWithLoggedOnUsers, then double-click on it and set its hex value to 1.
  5. You'll have to reboot for the change to be applied.

Another alternative - home or pro

If for whatever reason the approach above doesn't work, you can get around automatic reboots by changing your windows update settings so that you only download updates automatically and it requests approval before installing them. Once you approve installation you are at the mercy of when Windows reboots, but you have the ability to otherwise indefinitely delay it.

To change this setting:

  1. Press win+R; type regedit and press enter.
  2. Browse to the following registry entry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update
  3. Change the value of that key to a '3' (which configures windows update to download updates automatically but require user confirmation before installing them).

source

| improve this answer | |
  • 1
    Thanks, I am going to try this. In this question (superuser.com/questions/1112186/…) @SMackJack says that the group policy edit stopped working under the anniversary update, so I'll be curious to see if it works for me. – Ubiquitous Aug 11 '16 at 14:50
  • I saw conflicting information on it. The setting is still present. If it doesn't work the 3rd option will work. If you are running an insider build all bets are off, however – Argonauts Aug 11 '16 at 17:14
  • 1
    Thanks for this. Hope the options still are working. Win 10 Pro just restarted in the middle of watching a movie and updated for 30 mins, I could not change the time, and now I got even less options in Windows Update. Activity window of only up to 12 hours possible to prevent updates during that time? – Andreas Reiff Sep 30 '16 at 20:32
  • The newer editions of Win10 currently in the Insider Rings have expanded the flexibility of active times fixing this issue permanently. Full release of these features will probably be in the "Creators Update" scheduled for next year. – music2myear Dec 22 '16 at 0:36
  • 3
    Please note that NoAutoRebootWithLoggedOnUsers is not sufficient. See superuser.com/a/1192401/129204 – Dr. Gianluigi Zane Zanettini Mar 25 '17 at 23:16
0

Argonauts' method worked in previous versions of Windows, but it no longer works in Windows 10.

Here's a .zip containing a .reg file which SHOULD work even in Windows 10 (though I won't know for sure until the next time M$ pushes a Win10 update which requires rebooting):

http://www.geeksalive.com/NoAutoReboot_Win10.zip

Be sure to read the 00ReadMe.txt file.

Note that for this to be effective you'll need to either restart the Windows Update Service, or just reboot the computer, after installing the registry update.

| improve this answer | |
  • 1
    I am currently on Windows 10 version 1709, and have all those same values in my registry (I must have run this script before). Still, windows restarted for an update last night. – Johann Feb 16 '18 at 16:52
-1

Possible answer, still testing but seems to be working until MS changes these settings in the Task Scheduler.

On another post, "How to disable automatic reboots in Windows 10?", jakethedog references using the Task Scheduler. I expanded on the settings per items in the UpdateOchestrator.

Goto Start and enter Task Scheduler. Goto Task Scheduler Library >> Microsoft >> Windows >> UpdateOrchestrator.

Here you will find items that can be adjusted to cause Updates to behave differently. You can change different properties in each item by right clicking and selecting Properties.

You should see six tabs. Most have parameters that can be set, disabled, or deleted. Use the History tab on each item to see when and what these are processing. Then per tab make the desired changes.

So far, I've only Disabled and not Deleted any parameters. MS may re-add a deleted parameter when the update scans run, whether manually or automatically and replace missing items.

On each item I've adjusted, I've changed the following tabs.

General Tab >> Security options. Changed the user account controlling the item from System to my account. This should help the system account stop overriding changes.

Triggers >> Edit >> Advanced settings. Begin the task: On a schedule. Set Delay task for up to (random delay): to 1 day. Set Stop task if it runs longer than: 30 Minutes. Set Expire: the day you make a change to the item, 15 minutes later than when the change is made and to Sync across time zones. Unchecked Enable.

Actions >> Edit. Rename the Program/script entry. Here, I just changed MusNotification.exe to MNcation.exe and removed the Add arguments option of Reboot. This may be adding to the Event Viewer, I've not checked to see.

Conditions >> Power. Uncheck both entries.

Settings. Set to the following.

Settings Tab

Then select OK to close the Properties window and then Right click and Disable the item per item you adjust. Then reboot.

| improve this answer | |
  • You should edit this answer after you have verified it is an actual answer. Review – Ramhound Dec 15 '16 at 19:51
  • I went ahead and flagged this question as a duplicate, because of this answer, as a duplicate to this question: How to prevent Windows 10 from restarting the computer after installing updates identical answers to multiple questions isn't a good thing. If you find yourself submitting the same answer multiple times, stop yourself, because your answer will show up in the review queue. – Ramhound Dec 15 '16 at 19:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.