1

I have win 10 on my laptop. Surprisingly, it is 2 months that I can not open some of the websites on my laptop with any browser (Chrome, IE, Firefox, ...), especially the website of universities, even if I type the IP address of the website.

The problem is not form my internet provider because I can load those websites from my mobile via my WiFi (Not my sim-card's internet). Also I can open the websites from Ubuntu inside of a virtual box in my windows. The problem is not from firewall because I disable that and I had the problem again.

I think 2 possibilities may happen.

1- My laptop have some kind of virus, and it prevent visiting universities websites.

2- The windows can not find the DNS server for those websites. When I type ping www.the_intended_website.com it shows the correct IP address for those websites but the response failed because of timeout.

Any suggestion for solving this problem is appreciated.

  • The dns server used by the router could be having issues that would heal after a day or so. How long has this been going on? – Moab Aug 11 '16 at 20:32
  • @Moab It is more than 2 months. But it is not related to router. Because if it was related to the router why I can connect to those websites when I use other devices with same router. – Mahdi J.Ansari Aug 11 '16 at 20:40
  • Doesn't read like a DNS issue. If that was the case, your computer wouldn't be able to translate the domain name to the IP address. What errors do you get when you try to load the websites that are giving you issues? You see a 404 page, no internet warning, or something else? – Caturday Saint Aug 11 '16 at 20:45
  • 1
    So the sites just don't load? You get no indication of progress, or notification that they could not load? Pinging gives a timeout error? Only for those sites, correct? – Caturday Saint Aug 11 '16 at 21:10
  • 1
    Disabling ipv6 in WiFi properties solved a similar issue for me – Mark Robinson Oct 3 '17 at 20:03
4

I found this guide that covers this problem. It does say that this is for Google Chrome, but the majority of these solutions will work on any browser on your computer.

The basics are these:

  • Make sure the time and date is correct on your computer
  • Try temporarily disabling your antivirus to se if that works better
  • Check your hosts file for any incorrect information
  • Clear the SSL State (Control Panel -> Internet Options -> Content -> Clear SSL State)
  • Change the security and privacy level for Internet (Control Panel -> Internet Options -> Security) to medium

This last one will affect just Google Chrome:

  • Disable Chrome QUIC Protocol (go to chrome://flags/#enable-quic and select Disabled from the drop-down list under QUIC Protocol)
| improve this answer | |
1

I would try to use a public DNS such as google 8.8.8.8 or even try to open a VPN as hotspot shield and test it just to make sure it's not a connectivity issue and you can always check you host file but it's super unlikely to be modified by itself to block the websites you're trying to reach .

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.