0

I have Win7 on Asus p8Z77 MB, recently I've noticed that by having the hibernate turned on, it keeps eating away the storage capacity in my C drive by like 10G+ (OS drive), so I decided to turn the hibernate off using " powercfg.exe /hibernate off " in CMD.

Then something interesting happens: After hibernation being turned off, whenever the computer goes into a sleep mode, the display will be turned off as normal, yet the cpu and etc is still running in the background...not actually in sleep like it used to. And when I was trying to hit any keys or move the mouse to "wake" it up, the keyboard would be frozen (lights on there would stop triggering) and it just remains in the state forever with the black screen of death (cpu is still running) and there is nothing I could do at this point but to restart the PC.

Yet, by re-enable the hibernate function in CMD using powercfg.exe /hibernate on , the previous Semi-Sleep and wouldn't wake up problem goes away by itself, any idea why this happens and any fix?

0

First off, Hiberfil.sys will always be the same size as the amount of ram you have or approximately the same size as the amount of ram you have. This explains why it can be large sometimes. The more ram you have, the larger it needs to be as it stores everything that is in the ram, into this file.

Now for the problem you are having, not sure if you done anything extra or if you have extra software installed that helps with optimizations. But when you turn off hibernation, there is another sleep mode that also utilizes the same file that hibernation uses, and its called hybrid sleep. This is also known as a deep sleep mode as it, combines everything you get from hibernation and everything you get from sleep mode, so that in the event of powerloss while the computer is in this sleep mode, you don't lose your data but the computer can wake up like as if it was in normal sleep mode. If the file that it needs is missing, things can go wrong. Can't be specific as it varies.

if you don't need this sleep mode, you can disable it in the power options. And see if this fixes your problem.

Another solution could be, windows is not allowing your mouse or keyboard to wake the computer up. You can fix this by going into the device manager, find your keyboard. Go into the properties and check the box allow this device to wake the computer.

You can also try the windows troubleshooter in the control panel. Select trouble shooting, in the next window select improve power usage under system and security. This should detect any problems with your power settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.