After applying the anniversary update, Windows 10 decided it was okay to change various settings for me. I've reversed some of the changes but one persists and I can't seem to find where to fix it.

Let's say I have a number of applications running, with icons in the taskbar. I click on the icon for a minimized window. It restores itself to its previous size/position and takes focus, as expected and as wanted.

I now click the icon for the same window, still in focus. Nothing happens. What I want is for the window to minimize, as it did before the update.

Some things I have looked at:

  • Right clicked taskbar -> check "Personalization" -> "Taskbar". Found no option that would remedy the situation.

  • "System settings" -> "Multitasking" -> Looked through options for window behaviour; found nothing relevant.

  • Googled various combinations of "taskbar" "window" "minimize" "focus" and some other keywords. Mainly found articles and questions about hiding icons in focus and one question about wanting to STOP the behavior I'm looking to get back, but the solution suggested third-party software. The behaviour I want should obviously already exist natively, so I'm looking to change a setting, not install new software, although that could be a last resort should no other fix be found.

So, to clarify the question:
How do I change my settings so that a window in focus minimizes when I click its icon in the taskbar?


It is unlikely settings were changed, by you or by an update. This behavior, AFAIK, is not something you can alter or customize, even with registry edits.

This is likely a temporary bug. Try to gracefully restart Explorer.exe to solve the problem without a reboot.

Open up a command window with administrative privileges

Paste each line below, one at a time, followed by enter

taskkill /f /IM explorer.exe

If this doesn't solve the problem, try rebooting.

If rebooting doesn't handle it, use system restore to bring the system back to a date prior to the problem start date.

  • 8
    Sorry for the late reply, haven't been logged on here for a while - simply restarting explorer.exe worked wonders. – Jakob Pamp Bengtsson May 30 '17 at 13:35
  • 3
    I up-voted because I ran into the same issue, and this was a simple fix. However, on the second line shown, it isn't necessary to use "start"; explorer will run if you just type "explorer.exe". The Start command is generally used when you want to open a program in a new window; in this case, it's just not relevant. – Debra Apr 22 '18 at 19:26
  • 1
    @Debra, updated. good catch – Gaia Jun 7 '18 at 22:27
  • 3
    Restarting explorer.exe using task manager worked. – phpguru Sep 12 '18 at 19:45
  • 4
    I was having this problem this week, googled "clicking taskbar does not minimize", and this was the first hit. I wish I could upvote this Q&A twice, but I discovered that I had already upvoted it six months ago when I found it the first time I had this problem! – shoover Sep 20 '18 at 15:10

Open the Task Manager (by hitting Ctrl+Shift+Esc or any of the other methods).  On the "Processes" tab, scroll down to "Windows Explorer" and highlight it.  Click the "Restart" button in the bottom right corner of the Task Manager.  Applications like Windows Media Player will be working as full screen after this change too.

  • 2
    This was easier than the accepted answer and totally worked for me. – Don Rolling Jan 7 '20 at 16:26

Here is the convenient way to solve this repeated issue.

Take Gaia's answer with the three commands in it. Create a .bat file somewhere and paste the three commands into it (I called mine rex.bat). Create a shortcut to rex.bat on your desktop

Whenever the problem occurs (and it does repeat itself) - run the batch file and hey-presto - job sorted.

Remember to wait for explorer.exe to restart - it can take a few seconds sometimes.


In windows 10 build 14393.576 if you click on another window icon in taskbar to make it active window then click again to minimize it. Then that appears to solve the problem with the previous window which wasn't minimizing.

I haven't tested it on any other version/build.

  • Hello! Sadly, the bug still appeared on said build of W10. It annoyingly sorted itself out a couple of reboots later though. Guess I'll just have to hope enough reboots solves it if it shows up again. Thanks for your answer though. – Jakob Pamp Bengtsson Jan 23 '17 at 12:07

A permanent fix (although a bit annoying) is to simply click the "Restore" button just to the right of the minimize button (this restores the window to its default size (usually "normal" but can be "maximized") and then click the minimize button.

For some reason the "minimize" button sometimes becomes inactive (obviously a fault in Windows 10) and the way to quickly "fix" this is to restore the default size first. This re-activates the minimize button. :-)

  • 1
    This question isn’t about the “Minimize” button. – Scott Oct 29 '18 at 15:34

The highlighted answer with the restart explorer.exe didn't work for me, although I solved it as follows (I don't know if it's temporary or not): Shift+RClick on taskbar on the window with an issue. From the context menu select "Minimize". After this manipulation, the window should be minimized by simply clicking on it on the taskbar, as expected.

It worked on my Windows 10 v1809 build 17763.737


It appears to be an issue of the computer running out of resources (memory) Mine was doing the same thing and doing the restart of the Windows Explorer in the Task Manager did the trick and noticed afterwards that I had available resources and the program would minimize by just clicking on it again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.