2

I'm doing a Cordova tutorial and I wanted to enable Hyper-V for phone emulation. Problem was, when I went to toggle it in Control Panel, it said "Hyper-V cannot be installed: Virtualization support is disabled in the firmware." My CPU is a G2120, which supports virtualization, and I found a C:\Windows\Boot\EFI directory.

Running systeminfo.exe gives results ending with the following:

Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                           Virtualization Enabled In Firmware: No
                           Second Level Address Translation: Yes
                           Data Execution Prevention Available: Yes

I haven't had any luck accessing the BIOS by pressing Del or Esc while booting up, and when I used "advanced startup" in accordance with this how-to, "Advanced options" did not list "UEFI Firmware Settings".

2
  • 2
    If the motherboard's BIOS/UEFI shell does not provide an option tio enable virtualization support, then it cannot be enabled, even if your CPU supports it. You cannot use Hyper-V, if you cannot enable VT-x, you can use any other virtualzation product you want that doesn't have that requirement.
    – Ramhound
    Aug 12, 2016 at 22:20
  • 1
    "did not list "UEFI Firmware Settings"." - This means it cannot be enabled on the hardware you have. Your CPU might support it, but the firmware, must also support it.
    – Ramhound
    Sep 18, 2016 at 16:39

1 Answer 1

-3

You can enable the virtualization from UEFI settings. For this in Windows 8/8.1/10 go to settings -> update and security -> recovery -> restart now (advanced options).

There you will see the advanced options -> UEFI firmware settings -> system & conf. -> virtualization

You can enable it by pressing enter.

1
  • The OP has stated that he cannot see the option you have indicated.
    – Burgi
    Sep 18, 2016 at 16:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .