0

It is very annoying that when my mouse cursor leaves the window of my VMWare Player, it losts focus and I can't type anymore (lots of wasted energy).

So I checked if I could modify the input settings and found this documentation:

enter image description here

It shows that I can change the Input settings but it is for a very old version (v4) and I couldn't find any preference like this in my Player, I have only this:

enter image description here

How can I set these in my Player?

4
  • That documentation is actually for VMware Workstation, not for VMware Player. (VMware confusingly renamed Workstation to "Workstation Pro" and Player to "Workstation Player".) Anyway, see: superuser.com/questions/1044034/… – jamesdlin Aug 14 '16 at 13:16
  • @jamesdlin Thanks, I'll try it. However, you described a scenario about how weird it would be if VMWare wouldn't release the mouse when it is out of the guest. Well, VirtualBox handles it very smoothly, if the mouse is out of the window but the focus is still on the VM, it doesn't release the hook, but if you click on a host window, it releases. Very intelligent solution, VMWare should work the same. – Nestor Aug 15 '16 at 6:52
  • Enabling "Grab keyboard and mouse input on key press" (pref.grabOnKeyPress = "TRUE" in the preferences.ini file) should behave fairly similarly. If that's still insufficient, I'd be really curious to know what your use case is. – jamesdlin Aug 15 '16 at 7:17
  • @jamesdlin Using grabOnKeyPress is very close to the experience I had on VirtualBox. If they manage to retain the mouse cursor at its original (out of window) position, they catch up with the Oracle guys :) If you promote your comment to an answer, I'll accept it. – Nestor Aug 15 '16 at 17:56
1

That documentation is actually for VMware Workstation, not for VMware Player. (VMware confusingly renamed Workstation to "Workstation Pro" and Player to "Workstation Player".)

Workstation and Player share the same preferences file, so changing preferences in one usually affects the other product, even if that other product doesn't provide UI to change certain options. You could try manually modifying your %APPDATA%\VMware\preferences.ini file and adding pref.motionUngrab = "FALSE".

Alternatively uninstalling the VMware mouse driver in the guest should work too.

(Note that doing the above will prevent the mouse cursor from leaving the guest without doing an explicit ungrab; it will not allow you to move the mouse out of the guest while still being grabbed, which usually doesn't make much sense. If you want to be able to move the mouse out of the guest but to automatically grab when typing while the host window still has focus, you'll want to enable grab-on-keypress by setting pref.grabOnKeyPres‌​s = "TRUE" in the preferences.ini file.)

0

@jamesdlin's answer is correct, but there seems to be some hidden characters in the pref.grabOnKeyPres‌​s = "TRUE" text of that answer (and I don't have the reputation to edit it or comment on it). When I copied that text and pasted it into %APPDATA%\VMware\preferences.ini, VMware deleted the line on next launch.

To recap: Close all VM instances and add one (or both) of the following to %APPDATA%\VMware\preferences.ini. These work as of VMware Player 15.5.

pref.grabOnKeyPres‌​s = "TRUE" will allow you to move the mouse out of the VM, but keep the keyboard focus in the VM as long as the VM window has the focus. If you type a character, VMware will move the mouse back inside the VM, but not lock the mouse in the VM.

pref.motionUngrab = "FALSE" will lock the mouse in the VM anytime you give the VM focus and will require an unlock (usually CTRL+ALT) to free the mouse. This too solves the keyboard focus issue since the mouse cannot drift outside, but has added step of needing to unlock the mouse to work outside the VM.

You generally only need one of the two options. Personally, I prefer pref.grabOnKeyPres‌​s = "TRUE" as it behaves more like the standard Windows focus manager and is good if you move between windows a lot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.