1

Problem

Windows 10 Education x64 crashes on installing of Update 1607 without BSOD. I see Windows's ring progress indicator before the crash.

Goal

Updating Windows 10 Education x64 from Version 1511 to 1607 without reinstalling.

Hardware environment:

  • Mainboard: Asus Z170 PRO GAMING
  • HDD: Hitachi HDS5C3020BELE630
  • SSD: Samsung SM951-NVMe M.2 2280

Software environment:

  • Windows 10 Education x64 installed on SSD, all drivers up to date
  • Arch Linux x64 installed on HDD
  • Grub2 installed on HDD, chain loading to Windows Boot Loader on SSD
  • latest BIOS version

What I did

  1. Switched to new hardware.

  2. Copied Windows 10 x64 Version 1511 and EFI partition from HDD to SSD.

  3. Deactivated CSM and set Secure Boot option to "Other OS", copied the latest Arch Linux CD release to USB stick and booted from it.

  4. Chroot'ed into Arch Linux, reinstalled grub2 on HDD's EFI partition and recreated its config boot file.

  5. Set grub2 as primary in boot priority.

  6. Started Windows Update to install the Update 1607 (retried 2-3 times), deleted the Update 1607 download files.

  7. Downloaded and started the Windows 10 Upgrade Assistant (because Windows Update don't show me the Update 1607 again) and waited for MS to fix the download for Windows 10 Education.

  8. (After MS fixed the download) Started the Windows 10 Upgrade Assistant, verified my hardware meets the requirements and downloaded the update.

  9. Restarted the PC when download of the update is finished and booted Windows 10.

What I tried

  • Unplugged the HDD power and data cable from the HDD before I started the Windows 10 Upgrade Assistant. Same result.
  • Start update over the ISO copied to a USB drive (started setup.exe).
  • Asked at Microsoft's German Windows forum. -> Result: I should ask at a Linux forum for help or contact Asus support (not very helpful).
  • Contacted Asus support (I wait for a reply).

Anyone have an idea what I can try next?

UPDATE: Re-installed Windows, problem fixed.

  • How were you able to use the indows 10 Upgrade Assistant which cannot be used to upgrade VLK versions of Windows 10 to Version 1607 – Ramhound Aug 13 '16 at 21:06
  • 2
    Possible duplicate of Windows 10 Anniversary update fails on Education version – Ramhound Aug 13 '16 at 21:07
  • Not a duplicate, MS fixed this bug. – fireandfuel Aug 13 '16 at 21:09
  • Have you tried to download the .ISO and upgrade your installation that way? Based on what you have tried, I don't see that listed, and your the one having problems. I have multiple people, who I have suggested doing that in chat, and every single person had sucess. I won't be withdrawing my close vote for that reason. – Ramhound Aug 13 '16 at 21:11
  • I give at a try. :) Download it and install it on a USB device will do the thing? – fireandfuel Aug 13 '16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.