1

My gs's laptop goes to sleep at random times when she leaves it idle for as short time as 1 minute. I've checked the power configuration, and it should NOT be going to sleep at any given time, it's on external power so it's not a matter of battery saving.

I've checked the EventLog, but found very little. However, I found something that may or may not be related. Before a "going to sleep, f*ck you" event, I see an error.

Log Name: System Source: Microsoft-Windows-DistributedCOM Date: 10-Aug-16 9:32:23 PM Event ID: 10016 Task Category: None Level: Error Keywords: Classic User: SYSTEM Computer: DESKTOP-A2HFC0V Description: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2016-08-11T00:32:23.209527500Z" />
    <EventRecordID>9075</EventRecordID>
    <Correlation />
    <Execution ProcessID="872" ThreadID="4160" />
    <Channel>System</Channel>
    <Computer>DESKTOP-A2HFC0V</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="param1">application-specific</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{D63B10C5-BB46-4990-A94F-E40B9D520160}</Data>
    <Data Name="param5">{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}</Data>
    <Data Name="param6">NT AUTHORITY</Data>
    <Data Name="param7">SYSTEM</Data>
    <Data Name="param8">S-1-5-18</Data>
    <Data Name="param9">LocalHost (Using LRPC)</Data>
    <Data Name="param10">Unavailable</Data>
    <Data Name="param11">Unavailable</Data>
  </EventData>
</Event>

As I said, this may be completely unrelated, but I see it almost always like 1 sec before it goes to sleep. I looked online, and this seems to be an error related to RuntimeBroker.exe, it doesn't look like it should be responsible, but who knows.

This is a sleep event: Log Name: System Source: Microsoft-Windows-Kernel-Power Date: 10-Aug-16 9:32:24 PM Event ID: 42 Task Category: (64) Level: Information Keywords: (70368744177664),(4) User: N/A Computer: DESKTOP-A2HFC0V Description: The system is entering sleep.

Sleep Reason: System Idle
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
    <EventID>42</EventID>
    <Version>2</Version>
    <Level>4</Level>
    <Task>64</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000400000000004</Keywords>
    <TimeCreated SystemTime="2016-08-11T00:32:24.047432400Z" />
    <EventRecordID>9076</EventRecordID>
    <Correlation />
    <Execution ProcessID="4" ThreadID="4656" />
    <Channel>System</Channel>
    <Computer>DESKTOP-A2HFC0V</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="TargetState">5</Data>
    <Data Name="EffectiveState">5</Data>
    <Data Name="Reason">7</Data>
    <Data Name="Flags">0</Data>
  </EventData>
</Event>

Just in case, the current power config: enter image description here

Any ideas where I may look for additional info?

Thanks.

  • So is it actually sleeping, or is there a "blank" screensaver set, that starts at a very short interval? I haven't used a screensaver in years but there could be a setting that kicks off sleep when a screensaver starts? I'm just trying to throw out some ideas lol – DrZoo Aug 13 '16 at 23:37
  • You could also check Sleep under the advanced power settings to make sure it is also set to Never. – DrZoo Aug 13 '16 at 23:40
  • After looking through Google, I found this thread see if it helps you out any? – DrZoo Aug 13 '16 at 23:43
1

This problem has been reported occasionally on all recent windows versions, and is attributed to the power config not being properly parsed by the system.

The most effective solution is to create a new, identical power management plan, and set it as the default. The new plan can be identical in content to the old one.

Adding a new power plan is very straightforward. Here's an excerpt from this reference:

Steps to create a power plan in Windows 10:

Step 1: Open Power Options. Shortcut: WIN+R; powercfg.cpl followed by ENTER

Step 2: Tap Create a power plan on the left.

Step 3: Choose an option from Balanced (i.e. the default), Power saver and High performance, name the plan and click Next to continue.

Step 4: Change the sleep and display setting if needed, and hit Create to finish the task.

Step 5: On the main power configuration screen, powercfg.cpl, select your newly created power management plan so that it becomes the default.

Step 6 [Optional]: If there are additional power configuration settings that you'd like to apply that weren't exposed in the 'add new plan' menus, you can directly access the advanced settings with this shortcut: WIN+R; control powercfg.cpl,,1 followed by ENTER

You should reboot the PC after creating and applying the new config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.