1

I have a Logitech 310 Gamepad and windows 10. Sometimes the device works, but very rarely and I have no idea what triggers it to work properly.

Most of the time, the controller registers as an HID Mouse and an HID Keyboard (though I gather that it's supposed to show up as a Gamepad F310 when using X-input or Dual Action gamepad when using D-input).

Occasionally the gamepad gets detected properly and it works like it should. Sometimes this happens after waiting a while with it plugged in. Other times it's in the midst of flipping switches and settings. The gamepad has never worked immediately after being plugged in.

I have run the provided software (for windows 10, 64 bit), but the readme does not list windows 10 as an OS that it was designed for and it's dated 2010. I have rebooted with the controller plugged in. I have switched which USB port the controller is plugged into. I have made sure that the switch on the back is set to X, though I have also tried it set to D and tried switching it after it didn't seem to detect as the other. I have run windows 10's Set up a USB gamepad controller functionality (this worked once, but has not since). Most of the time the device doesn't show up on here at all. I have run the profiler while trying to get it recognized as I read that was someone's solution on the forum (though I have yet to see anyone claim their devices are showing up as HID keyboards or mice).

I am willing to try anything suggested, including things I have already tried if it means that I might have a reliable way of making this controller work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.