I'm running Tunnelblick 3.6.6beta02 (build 4581) OpenVPN client on OSX El Capitan.

The problem is, if I change wifi network, I couldn't connect to my OpenVPN server no and it says "Waiting for a server response..."

The only workaround is to restart computer or do the following command in the terminal, which is frustrating to do each time:

sudo ifconfig en0 down
sudo route flush
sudo ifconfig en0 up


2016-08-16 11:03:48 SIGUSR1[soft,tls-error] received, process restarting
2016-08-16 11:03:48 MANAGEMENT: >STATE:1471334628,RECONNECTING,tls-error,,,,,
2016-08-16 11:03:48 MANAGEMENT: CMD 'hold release'
2016-08-16 11:03:48 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
2016-08-16 11:03:48 TCP/UDP: Preserving recently used remote address: [AF_INET]x.x.x.x:xxxx
2016-08-16 11:03:48 Socket Buffers: R=[196724->196724] S=[9216->9216]
2016-08-16 11:03:48 UDP link local: (not bound)
2016-08-16 11:03:48 UDP link remote: [AF_INET]x.x.x.x:xxxx
2016-08-16 11:03:48 MANAGEMENT: >STATE:1471334628,WAIT,,,,,,
2016-08-16 11:03:48 write UDP: Can't assign requested address (code=49)
  • The same problem for me. You are not alone.
    – ipeacocks
    Jan 27 '18 at 23:03
  • Same here. Got any solution? Mar 26 '20 at 6:36
  • @JinuKurian no, I just assigned hotkey combination to reload Mar 26 '20 at 10:04
  • @icherevkov: I need to turn off wifi and disconnect tunnelblick then do the "sudo route flush" then turn wifi back again. What did you meant by reload? Mar 26 '20 at 11:41
  • 1
    @JinuKurian running command sudo ifconfig en0 down && sudo route flush && sudo ifconfig en0 up Apr 15 '20 at 19:37

This appears to be a bug in Mac OSX, at least from what I can see in other similar posts. But no one seems to have the know how to fix this in Mac. Best thing I can do is restart my computer, which is kinda annoying


It appears removing the user nobody group nogroup

in the server conf file helps. You set up the routes as root, but when you disconnect you no longer have the rights to reflush.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.