0

EDIT: I got it working, for some reason seems uninstalling XNA Framework got it working, the other frameworks didn't even matter, I didn't suspect XNA since it came with a different program but oh well, atleast it works now.

Ever Since I updated my Windows 10 I can't get Visual studio to intall, each time I try to install it, I get this: http://prntscr.com/c6cuib no matter what options I check in the installation box, I ran it as an administrator, have no antivirus active, disabled windows firewall, troubleshooted windows update, all for nothing.

I once got it to install but it was not useable: http://prnt.sc/c6cfb3

Any ideas?

EDIT: The errors from the log file:

Error 0x80070002: Failed to move verified file to complete payload path:
C:\ProgramData\Package Cache\{DE064F60-6522-3310-9665-B5E3E78B3638}v14.0.23107
\packages\communitycore\Setup\cab6.cab

Error 0x80070002: Failed to cache payload: cab4F7DEE837DFF7D88E4EA825A6F68F405

MUX:  ExecuteError: Package (vs_communitycore) failed: Error Message Id: 1317 ErrorMessage: Error 1317.An error occurred while attempting to create the directory: C:\ProgramData\Microsoft\HelpLibrary2

Error 0x80070643: Failed to install MSI package.
Error 0x80070643: Failed to execute MSI package.
Error 0x80070643: Failed to configure per-machine MSI package.

MUX:  Return Code:0x80070643 Msi Messages:Error 1317.An error occurred while attempting to create the directory: C:\ProgramData\Microsoft\HelpLibrary2 Result Detail:0 Restart:None

 Error Message=Error 1317.An error occurred while attempting to create the directory: C:\ProgramData\Microsoft\HelpLibrary2, Result Detail=, Vital=True, Package Action=Install, Package Id=vs_communitycore

Error 0x80070643: Failed to execute MSI package.

Error 0x80070643: UX aborted cache verify begin
18
  • The installer's log indicates the reason it failed. Can you provide that reason?
    – Ramhound
    Commented Aug 16, 2016 at 10:49
  • From the bottom to the top these are the first errors I can see: [18D8:1FCC][2016-08-16T13:52:07]e000: Error 0x80070643: Failed to install MSI package. [18D8:1FCC][2016-08-16T13:52:07]e000: Error 0x80070643: Failed to execute MSI package. [2210:0F00][2016-08-16T13:52:07]e000: Error 0x80070643: Failed to configure per-machine MSI package. But I am not too good at reading logs. Commented Aug 16, 2016 at 10:53
  • I can't read I errors that are not formatted.
    – Ramhound
    Commented Aug 16, 2016 at 10:55
  • I also found ExecuteError: Package (vs_communitycore) failed: Error Message Id: 1303 ErrorMessage: Error 1303.The installer has insufficient privileges to access this directory: C:\ProgramData\Microsoft\HelpLibrary2. The installation cannot continue. Log on as administrator or contact your system administrator. How is this error even there? I am administrator of my system, I placed the installer on my C: drive where I'm also installing VS and I always run it as an administrator, I went to that directory and the folder isn't even there! Commented Aug 16, 2016 at 11:01
  • It isn't there because of a permission problem hence the reason it generated the error and the installation rolled back. I cannot read errors in comments.
    – Ramhound
    Commented Aug 16, 2016 at 11:06

1 Answer 1

0

Uninstalling XNA Framework worked in my case, but a good thing to try is search for "frame" in Programs and features and uninstall anything related, then proceed installing Visual Studio, as recommended by @barlop in the comments.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .