Hey so I'm having issues with the windows 10 search bar on the bottom left which are it really slow, and it not finding files. I just upgraded from windows 8.1 and I absolutely LOVED the charms search bar because it found anything I was looking for in a split second.

When I first got windows 10 the search bar would only look for things in the C drive, so I looked up some stuff and found that I had to re-index my other drives (also deleted cortana because she was irritating). That temporarily fixed the problem of files not being found, but it also made the searches take a really long time to find results. But, after a few days I noticed that the search bar wasn't finding new files downloaded after the indexing date. Re-indexing seems to fix the problem but my computer has a few million files and I'm not willing to rebuild every few days.

Anyone have any ideas to why the search is slow/not updating, and how to make it more like windows 8.1's?

Also does anyone happen to know if windows 10 uses a different search algorithm than windows 8.1

  • How often and how many files do you add each day?
    – Moab
    Aug 16, 2016 at 22:05
  • often and a lot. I'm constantly adding and removing new things/ backed-up software stored in my network server, but i don't see how it would be a problem now. Everything worked lightning fast in windows 8.1 and windows 10 is suppose to be an improvement. I know I can stay with windows 8.1, but the way Microsoft is updating with things such as direct x 12, etc. I know I won't have a choice but to upgrade at some point in the future. Aug 16, 2016 at 22:57

2 Answers 2


A shot in the dark here, but did your automatic indexing get turned off by chance? To check, open Windows Explorer and right-click on your C:\ Drive (or whatever drive you are wanting to search if you have multiple) and select Properties. At the bottom of the General tab, there's an option that says, "Allow files on this drive to have contents indexed in addition to file properties".

Properties on C: Drive

If that's checked, it can still be overridden lower down in the tree. By that, I mean if the C:\Windows\System32 directory properties has that same checkbox unchecked, then that directory (and the subdirectories) will not be indexed. Therefore, you want to make sure that whatever folder(s) that contain the things you are searching for have this checkbox checked. Note that further down the tree, you have to click the "Advanced" button on the General tab to get to this checkbox. At the top level, it's just on the General tab.


1- Run services.msc (via Windows + R buttons then type it or via Control Panel) and make sure Windows Search is enabled and started. You should see the result immediately.

2- Go to Indexing Options, chose Advanced then choose to 'Rebuild the index'. If this fixes the problem as you say every time then simply try the next suggestions.

3- Go to "Settings". Open "Privacy" settings then click on "Background apps" section.Enable Let apps run in the background. Restart your PC.

4- If previous solutions didn't work, you might try this one which is reinstalling Cortana package. Open PowerShell window either by right clicking on the start square icon in the corner then selecting Windows PowerShell (Admin) or by running command prompt as administrator then typing powershell then Enter.

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

This might result you an error in read color though (I can't post an image right now, sorry). So you might have to end the Cortana process from the task manager and once ended, quickly apply the command. My Cortana process in Windows 10 Creators update could be found in the task manager under the Details tab with name SearchUI.exe and description Search and Cortana application. Of course to end the process, right click and choose End task.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.