8

I use Outlook 365.

I like the fact that emails appear in Outlook Notifications (and I know how to turn them off if I wouldn't - see How to turn off Outlook Notifications?)

However what irks me is that the notifications appear a good minute or two after the email appears in my Inbox. That way, if I saw the email already in my Inbox, and dealt with it, then I am reminded about it again afterwards.

Is there any way of making the notification appear immediately that the email is received?

There do not seem to be any settings that control the time-delay between the receipt of the email and the display of the notification. I am not sure what else to try.

0
4

Turning on notification in Outlook does not guarantee Windows 10 will honor them. So, you have to ensure Windows 10 notification settings are set to allow notifications from the application (they may be in the Action Center, but not displayed on the Desktop).

If you already have Outlook configured to display the desktop alert, then follow these steps to configure Windows.

  1. In the Action Center (in the bottom right corner, next to your time) click on All Settings. An alternative method to open the Settings app would be to open the Start Menu and then click on Settings.
  2. Click on: System.
  3. From the panel on the left select: Notifications & Actions.
  4. In the “Show notifications from these apps” section at the bottom, click on Outlook. (If Outlook isn’t listed, you haven’t received a new message yet so Outlook isn’t registered yet as an app that receives notifications. Simply send yourself a test message in that case and reopen the Settings app. Also note that you must be using Outlook 2013 or Outlook 2016 as Outlook 2010 and previous have their own notifications which do not integrates with Windows 10)
  5. Make sure that you have enabled all notification options.
  6. Close Settings.

You may or may not need to restart Outlook.

Source - Not getting New Email Alerts on Windows 10

If this doesn't fix the issue, you may need to perform a repair install of Office.

0
3

This fixed it for me

  1. Run Outlook as a Administrator
  2. Disable Outlook notifications in the notifications in Settings -> System -> Notifications & actions -> Show notifications from these apps.
  3. Exit Outlook
  4. Run Outlook as administrator again
  5. Re-enable the notifications
  6. Restart the computer

Source: https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_windows8/outlook-new-mail-alertspopup-delayed/204f15e6-b5a7-4a15-8aa1-664870755ac9

1

Turning OFF then BACK ON the Notification feature on BOTH Outlook 2016 AND "Mail" fixed this annoying problem for me.

Step-by-step actions:

  1. Go to Windows 10 Action Center: Click Windows lower right hand corner "Notifications" icon)
  2. Select "All Settings" -> "Systems" -> "Notifications & Actions"
  3. Scroll down to find "Mail" and "Outlook 20XX", then TOGGLE EACH one from "On" to "Off", then exit Action Center
  4. Go back into Action Center "Notifications & Actions" menu, then TOGGLE back "Mail" and "Outlook 20XX" back from "Off" to "On"

Taking these simple steps fixed my problem. I am now getting Email notifications Real-time as the new emails arrive, no more grouped up pop-ups & email arrival sounds!

0

I had this problem and fixed it by deleting my Mail profile through Control Panel and then setting up my email accounts again

-1

I have had this problem and it seemed to be resolved by deleting bad message rules. YMMV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.