0

I've got a Cisco Linksys E2500 router that we used to use for our home wifi a few years back (we've had an ISP-provided modem/router combo for the past couple years at our last apartment), and I can't connect to the internet wirelessly through it. I'm finally able to connect via a wired connection (the default IP address - 192.168.1.1 - was the same as what the ISP-provided modem uses; changed it to .2 and wired is OK) and get internet access that way, but wirelessly I can only connect to the router without internet access.

When I connect my laptop (Windows 7 ok apparently Windows 10) wirelessly, I get

SSID
connected, no internet

This morning, my Android (Nexus 6, Android 6.0.1) would get stuck on the "Obtaining IP Address..." stage of connection. Now it gets to the same place as the laptop (connected, no internet) before starting the connection attempt all over.

The firmware version of the router is 1.0.0.

I've tried pinging 192.168.1.1 and 192.168.1.2 (the router and the modem, respectively) from my laptop while connected via wifi, and both of them yield

Reply from 192.168.1.5: Destination host unreachable.
Request timed out.

where 192.168.1.5 is the IP address of the laptop when it's connected via Ethernet.

How can I get devices wirelessly connected to the router to access the internet?

  • Have you logged in to the router and changed/setup the settings? – Tim G. Aug 18 '16 at 0:15
  • @TimmyJim yes, I've changed the SSID and password, and the password to log into the router. – yoozer8 Aug 18 '16 at 0:18
  • 1
    Static or DHCP? What browser are you using from Win10? – ejbytes Aug 18 '16 at 5:42
  • Can you log into your router? Is MAC filter enabled and back to question above this one; static or DHCP on router? – ejbytes Aug 18 '16 at 5:43
  • @ejbytes DHCP was disabled. I tried enabling it and rebooting the router; this seems to have fixed the problem. Thanks! – yoozer8 Aug 18 '16 at 11:01
1

As the OP indicated this was the problem:

  • Log into the router and check if MAC filtering is enabled. If so, you must enter the MAC address of your new device. Or disable this feature if you find that it's not necessary at this point.
  • Log into the router and check if static IP or DHCP is being used.

    If you are not using static IP's and haven't entered each IP independently then make sure DHCP is enabled in the router and reboot the router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.