0

So recently I got an old computer from a friend so had a computer to do linux-stuff on, an Asus K50ID. The computer works without any issues and I have been able to dual boot Windows 10 and Ubuntu 16.04, both in 64x.

I decided it would be nice to just upgrade the entire system to a SSD, so I ordered a ADATA SP550 120GB that arrived in the mail today. Put the drive in, booted up the Ubuntu from a bootable USB and started installation, and got this message:

error message

I tried several times to install with the same issue, and after a while I tried to install windows 10, just to see if that would work. The Windows 10 Installer got stuck on preparing files, sometimes on 67%, sometimes on 91%, and on other percentages too.

I then put the SSD into my old Asus eee 1005ha and tried to install Ubuntu there, which succeeded without issues. If I then put the drive back into my K50ID it would boot Ubuntu but I'd have no write-permissions anywhere on the drive, and couldn't even launch firefox without getting an error message.

When I'm searching on google for the same issue it seems that the issue seems to be with the BIOS, and that there are no options for AHCI in the K50ID BIOS.

Am I totally out of luck on running my computer from an SSD? Could it work with another SSD-model?

UPDATE: So I was finally able to install Windows 10 on the computer: just redid it a couple times until it came through. I still need it to be able to boot Ubuntu though.

UPDATE 2: So this shows up during my boot up:

image of boot up

If I'm reading it right this means my system is handling the AHCI-part fine, but I'm still not able to install Ubuntu, same error as before.

| improve this question | | | | |
-1

It looks like hardware issue.

  • check SMART of your SSD (smartctl --all /dev/sda)
  • check your optical drive, it look like defective
  • id you encounter error during installation of Ubuntu change the console (Ctrl+F2, you can also try other function keys, GUI are usually at Ctrl+F7) and type dmesg for kernel messages. Maybe it tell us more about issue.
  • try upgrade Asus bios and firmware SSD if possible
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.