1

I've tried to Install an Intel network driver for my laptop. It's Intel 825xx 10/100/1000 Ethernet Controller Driver Version: 18.1.0.0 ,A08 (I got it from the Dell Support Website which told me this was one of the drivers fitting my device).

According to the log, it fails with:

Installation was not successful. The most likely cause is no supported network connection exists on this platform.

What's that supposed to mean? Do I need to plug a LAN cable into the LAN adapter, so that a network connection can be established before the driver will install properly? Or is the LAN network device out of order? Or something else?

I've tried that on Win7 and (following automatic upgrade) Win10 - same error all the time.

I further tried installing with "Intel Device Manager Diagnostics Utility" available from the same website. It said it installed nothing since no network connections existed and no Intel adapters were found.

Edit: Additional info as requested by first three comments:

  • It's a Dell Latitude E6420
  • Listed under Device Manager > Network Adapter is a Intel(R) Centrino (R) Ultimate-N 6300 AGN. According to it's properties it's working fine.
  • The full configuration is at: http://www.dell.com/support/home/de/de/dedhs1/product-support/servicetag/CXX92Q1/configuration and I suppose that list is up-to-date as told to the website by the Dell System Detect utility. The list of network adapters is empty. It's a Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz CPU with NVIDIA NVS 4200M GPU, BIOS Version A04. Please ask if further info is needed.
  • Device Manager lists three (3) devices with exclamation mark signs. Their IDs are: 1.) (unknown device, saved at: "Stammkomplex für PCI-Express") ACPI\VEN_SMO&DEV_8800 ACPI\SMO8800 *SMO8800 2.) (Broadcom USH, saved at 0000.001d.0000.001.008.000.000.000.000) USB\VID_0A5C&PID_5800&REV_0101&MI_00 USB\VID_0A5C&PID_5800&MI_00 3.) (mass storage controller, saved at PCI-Bus 11, Gerät 0, Funktion 1) PCI\VEN_1217&DEV_8231&SUBSYS_04931028&REV_03 PCI\VEN_1217&DEV_8231&SUBSYS_04931028 PCI\VEN_1217&DEV_8231&CC_018000 PCI\VEN_1217&DEV_8231&CC_0180
  • I've spoken on the phone to Dell support (on an ordinary phone number - they spoke to me for about 30+ minutes even though there's no more warranty on this device). They suggested I downgrade to Win7 (despite the same problem occuring when using Win7) and try to install the driver/s there. In passing they mentioned that maybe there was an issue with the network adapter itself or with its plug that connect it to the mainboard.
  • right click your start menu button, then select Device manager. Fine the Network Adapters, to the left of it, click the arrow. It should list all your network adapters. Could you share of what it says there, also can you share your model of computer you have as well? – Frostalf Aug 18 '16 at 9:34
  • Can you share the configuration of your model, That would help us troubleshoot the problem – Krish Munot Aug 18 '16 at 9:43
  • 1
    In addition to Frostalfs answer, if you find the Network Adapter with a yellow exclamation mark, go to Properties and look for Details > Hardware IDs. Post the very first Hardware ID so we will be able to tell what Device you are talking about. – Steven Aug 18 '16 at 10:09
  • @Frostalf thanks for that, please see edited post for answers. – HumanInDisguise Aug 18 '16 at 11:42
  • @Steven thanks for that, please see edited post for answers. – HumanInDisguise Aug 18 '16 at 11:42
1

Had the same issue on my Latitude E6430. Turns out, that the network card was disabled in the BIOS. Obviously, the operating system had no chance of detecting the Intel(R) 82579LM Gigabit Network adapter.

Once, I turned in on there, Windows automatically installed the required drivers.

0

THose are the drivers I found:

Chipsatz-Treiber : http://wikidrivers.com/wiki/Intel_Chipset_Device

Kartenleser : http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/latitude-e6420?driverId=KC9W0&fileid=2731102815

Broadcom USH : http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=R308326

  • erm ... thanks for your effort. So my device needs a Memory Card Reader Driver and a Biometric Framework Integrated Driver to go on Ethernet? Just wondering because intuitively I wouldn't guess these were connected. – HumanInDisguise Aug 18 '16 at 12:01
  • No they are not needed to get an internet connection but those are the Hardware IDs you posted. If you do not want to install the other ones that is fine. For internet access only install the Broadcom-Driver – Steven Aug 18 '16 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.