0

I'm having issues downloading stuff from a rented remote server using a couple of different connections. S/FTP/HTTP/HTTPS file downloads, but not uploads, are all giving me issue.

If I start downloading through FTP (using Filezilla), files transfer for a few seconds, and then I get a "Error:Connection timed out after 20 seconds of inactivity". With smaller files, I can get them to transfer 100% by waiting until they freeze, stopping the queue, and reattempting the download, which grabs a bit at a time until they are finished. MD5s match, so data is not corrupted. Uploads using FTP work fine, even with exact same files.

Using HTTP, Chrome starts downloading the file, balloons in "Time Until Finished", and then a few seconds later cancels due to network error. Other servers in the cluster, with different addresses, work fine. I've downloaded other files from the same cluster, as well as other servers, to the same PC - no issue there either, so it doesn't seem like a hardware issue. HTTP pages on the server are served correctly, so I can load webpages from the same remote server, but not download files. No other server or website seems to be displaying the same problems, and until last week there were no issues with my remote server.

The server host says nothing appears off on their end, even when examining the connection from my IP specifically. I've tried other PCs on the same LAN, and every other device works fine and transfers the same files from the same server with no issue. The same is true of transferring from my mobile device over LTE, where everything works as intended. PC is connected using Ethernet, so no wonky wireless. I've tried using VPN to change connections, which doesn't help - so it seems to be some sort of local issue. It seems to be specifically linked to my one machine.

I have Malwarebytes Professional (paid) installed, as well as practice safe internet practices, and nothing seems amiss or malware-ridden. Hosts file has no entries that would block at the OS level, and Firewall doesn't have any odd entries. I've never seen anything like this, and have no idea where to even start diagnosing it.

What could cause my PC, and only my PC, to freeze file downloads from a specific remote server, when uploads to the same server work fine and other devices on the same network as me download those files with no issue?

  • 1
    Can you provide a packet capture which demonstrates the issue? I'd be happy to take a look over if you can upload it somewhere. – Mark Riddell Aug 18 '16 at 18:59
  • @MarkoPolo Please email me for a link to the file, which I've zipped and uploaded, as the information within isn't something I care to post everywhere. Thanks for the help. drpfenderson@gmail.com – drpfenderson Aug 18 '16 at 20:53
  • I've had a look over the capture now and can see there is packet loss which the connection(s) fail to recover from. I have a suspicion as to what is going on however I would really need to see the other side of the connection to get a clear picture of what is going on. Do you have backend access to the server? – Mark Riddell Aug 20 '16 at 16:27
  • I have elevated user status, but not full admin. I can install simple scripts or programs that do not exist outside of the user directory, but do not have root access. – drpfenderson Aug 25 '16 at 15:36
  • Sorry for the delay. Ideally, I would like to see a traffic capture of this issue from the server side as well? Do you have sufficient access to run a tcpdump? – Mark Riddell Aug 26 '16 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.