2

I've got a media / gaming PC setup in my living room, with two accounts on it; mine, a password-protected administrator, and a regular user, called "Steam".

Since I installed Windows on a 120GB SSD, I decided to put my account's folders in another drive. These consists of anything from media, pictures, to work-related files and personal documents.

I have the "Steam" account set up the same way.

The problem is that the Steam account can access my files and folders, and doesn't ask for my account password, as far as I can tell.

Ideally, the Steam user would have read-only access to my videos and pictures, while having zero access to my files and folders. The folders do not have the "Share" option ticked.

How do I do this?

5

Have a look at some of the File and Folder permissions settings. Right click on the files/folders you don't want 'Steam' to access, click the 'Security' tab, then 'Edit' under permissions. Then navigate through the list of users displayed, select 'Steam', and select 'Deny' under 'Full Access'. Hopefully the website I linked should help if you get stuck.

  • Okay, I don't see a Steam user. I only have the following: Authenticated Users, SYSTEM, Administrators, Users. IIRC, last time I did anything even my account couldn't access it. – zack_falcon Aug 20 '16 at 5:52
  • Got it. I just added a new user. – zack_falcon Aug 20 '16 at 7:10
  • 1
    Isn't the point to deny any user other than the one authorized for it? Explicitly denying a single user still allows other accounts access it would seem... – BuvinJ Oct 17 '18 at 15:36
  • The point is to deny only the Steam user access, as that is what the question asked. – Bilfred Oct 21 '18 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.