10

I have successfully installed VMWare Workstation 10 on my laptop running Windows 10. The virtualized system is CentOS.

Could install guest system and run it

I could successfully install the system and all, but after upgrading to Windows 10 Anniversary Update, I get this:

enter image description here

Removed Hyper-V

I have uninstalled everything from the system concerning Hyper-V. I removed it from my computer and restarted several times. No luck.

9

I had the same issue. Removing and disabling Hyper-V did not help. Turns out the problem was related to Device guard (I have Windows 10 Enterprise). I found the answer here. But the gist of it is

  1. Download the Device Guard and Credential Guard hardware readiness tool

  2. Run the tool in powershell with the correct execution policy)

    DG_Readiness_Tool_v3.2.ps1 -disable
    
  3. Reboot
  4. Make sure you have Hyper-V uninstalled and disabled

    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All
    bcdedit /set hypervisorlaunchtype off
    
| improve this answer | |
  • The downvote seems undeserved. This indeed solves the problem on Windows 10 Enterprise, and is otherwise a very hard to find solution. You should stick around during the reboot, though, as Windows will ask you to confirm you want to opt out. – Michael Hampton Jul 26 '18 at 0:25
  • 3
    For step 4 I get Disable-WindowsOptionalFeature : A parameter cannot be found that matches parameter name 'All'. – Barkermn01 Dec 7 '19 at 11:45
  • There is a extra space in the last command. it should be Microsoft-Hyper-V–All – Mery Ted May 16 at 4:53
3

Windows 10 should have an option in the boot configuration data which determines whether Hyper-V starts during Windows startup (there is in Windows 8.1). So to disable Hyper-V from starting, in an administrator command prompt you type: bcdedit /set hypervisorlaunchtype off and reboot the computer. After that you can run VMs in Workstation.

To turn Hyper-V back on again, type in an administrator command prompt: bcdedit /set hypervisorlaunchtype auto and reboot the computer. (Source)

| improve this answer | |
2

The solution to this problem is just disabling Device Guard. Below I show you how to disable it:

  1. Open gpedit.msc

  2. Go to Computer ConfigurationAdministrative TemplatesSystemDevice Guard. On the right side double click to edit the properties of "Turn On Virtualization Based Security". Set the setting to "Disabled".

  3. Open cmd as administrator and type the below commands:

    mountvol X: /s
    copy %WINDIR%\System32\SecConfig.efi X:\EFI\Microsoft\Boot\SecConfig.efi /Y
    bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"
    bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS
    bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=X:
    mountvol X: /d
    

After doing this you have to reboot and approve the changes with F3.

| improve this answer | |
1

Quote from https://www.reddit.com/r/Windows10/comments/9zqbo0/running_both_hyperv_and_vmware_workstation/:

Hyper-v is a type 1 hypervisor, vmware is type 2. They cannot coexist (on any OS).

However, you can create a second boot entry so you can boot in hyper-v mode or vmware mode.

https://www.hanselman.com/blog/SwitchEasilyBetweenVirtualBoxAndHyperVWithABCDEditBootEntryInWindows81.aspx

C:\>bcdedit /copy {current} /d "No Hyper-V" 
The entry was successfully copied to {ff-23-113-824e-5c5144ea}. 

C:\>bcdedit /set {ff-23-113-824e-5c5144ea} hypervisorlaunchtype off 
The operation completed successfully.
| improve this answer | |
  • 1
    This is what does (and has) always worked for me. I use a BCD boot option to switch between hypervisor on or off. – Señor CMasMas May 6 at 18:11
0

The presented DG_Readiness_Tool woks well unless you are in corporate environment where the uninstalled Device Guard may be reinstalled by central policy.

To overcome that I did this:

gpedit.msc -> set Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security to Disabled

| improve this answer | |
  • This is a good point. However, in most corporate cases, this group policy will also be forced by the company i.e. overwritten with the next GP update. Therefore, chances are rather low that this will work. – Andreas Feb 16 at 8:42
0

Good news! the Vmware Workstation 20h1 preview version has supported Hyper-V,you can download it here: https://blogs.vmware.com/workstation/2020/01/vmware-workstation-tech-preview-20h1.html

| improve this answer | |
  • It appears Hyper-V support will only support Intel Skylake or later CPUs. – Ramhound May 6 at 17:44
-1
  1. download the ADK.exe
  2. After downloading it , press WIN + F and search for Compatibility Administrator(64 bit).
  3. After opening the Compatibility Administrator(64 bit), expand System Database(64bit)
  4. Now Expand the Applications and search for VMware Workstation Pro.
  5. After getting it click on the VMware Workstation Pro and in the right
    there would be two components. a> vmplayer.exe b> vmware.exe
  6. right click on the both option independently and choose Disable Entry option on both the components .
  7. after clicking that you will get the red colour at both components.
  8. after that go and open VMware .
| improve this answer | |
  • These instructions suck.. even if they might work. – Señor CMasMas May 6 at 18:08
-2

I had the same problem. It comes with the anniversary update of Win10. This update add an extra security functionality but hyperV stuff is necessary to activate this function. Here is the kb to workaround the problem : https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2146361 It works for me. Mika (from France, so be cool with my poor english !!)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.