0

Everytime I restart my laptop, the power plan keeps reverting from my custom one to "High Performance". I don't have any battery life managers installed on my computer. I have MSI System Control Manager but that shouldn't be causing problems.

OS: Windows 7 Ultimate x64
Computer: MSI GP-60 2PE Leopard

1
  • it is likely to be a piece of software. Like the motherboards and manufactured computers supply software and they think they are helping by controlling that (without asking the user first). Use AutoRuns to disable startup and run junk, try and find it that way. or Use your task manager and the "services" stuff to locate what is causing it.
    – Psycogeek
    Aug 21, 2016 at 6:58

2 Answers 2

1

Sooner or later people wander into the "grey" area of windows static settings.

We humans know a light switch is either on or off by seeing a light connected to the switch being on or off.

Microsoft stores this in the registry and sometimes has problems storing in the registry.

Try changing the settings using the Advanced Power Options dialog box: http://www.laptopmag.com/articles/windows-advanced-power-options-explained

Set-it ... reboot, check that its still set to High performance, then re-set it back to the performance level you want (still using the advanced dialog) and then reboot again.

3
  • My custom power plan already has "plugged in" settings from High Performance and "on battery" settings from power saver (both apply in advanced settings). Is Windows deciding that my plan is unnecessary? Aug 23, 2016 at 12:21
  • i found the registry key that stores the selected power plan, and it was not being updated when the plan was changed. For now, I can just change it there. Oct 18, 2016 at 5:37
  • I found a key called HardwareOverride in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}. Is that of concern? There was nothing but (Default) being set to Power Options. Dec 4, 2016 at 4:57
1

First Thing to Do Before Trying Any of the 3 Methods Below

  1. Open the command prompt and type powercfg -l. You will be greeted with a list of available plans.

  2. Copy the GUID for the plan you want and paste it in Notepad for later use. Example: 381b4222-f694-41f0-9685-ff5bb260df2e for "Balanced".

  3. Remember to restart after performing any of the methods so that your changes will take place.

Method 1: "powercfg" Command-Line Utility

In the command prompt, run powercfg.exe -s <GUID> and replace <GUID> with the GUID you copied earlier.

Method 2: Registry Editing

  1. Open Registry Editor.

  2. Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}.

  3. Replace the value of PreferredPlan with the GUID you copied before.

Method 3: When All Else Fails

  1. Goto %appdata%\Microsoft\Windows\Start Menu\Programs\Startup.

  2. Create a shortcut.

  3. In the target, paste powercfg.exe -s <GUID> and replace <GUID> with the GUID you copied earlier.

  4. Call the shortcut anything you want.

For me, method 3 was the only thing that worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .