1

I am currently using LXDE as my desktop environment, but for my file manager, I much prefer Caja because it handles things more to my preference.

So, while pcmanfm is managing my desktop, Caja is used as a file manager. This doesn't work 100% as desired, however. If I open any of the folders on my desktop, they are opened in pcmanfm, not Caja.

At one time, I was able to use Caja to manage my desktop, which solved that problem. But now, Caja seemingly can't manage the desktop at all (or at least, it can't do so outside of Mate).

Is there any way that I can get my desktop folders to open up in Caja, rather than pcmanfm? Or, failing that, is there a way to get Caja to manage my desktop in LXDE?

My operating system is Lubuntu 16.04

Footnote: While simply switching to the Mate Desktop would solve this problem nicely, Mate does not work to my preference (in particular with its panel).

EDIT 1: Editing xdg-open and replacing pcmanfm with caja does not seem to work. It'll open a directory in caja if I try running 'xdg-open /directory/path' in a terminal, but desktop files still open in pcmanfm

0

Go in preferences and look for default applications. Here, change your default file browser to whatever you want and click OK. You may want to restart Xserver after this. This will lead to opening everything in the specified file browser.

1
  • That's how I originally tried setting Caja as my file browser. The problem is that desktop folders are still being opened in pcmanfm. I think I'm going to adjust the title to this question. – Zauber Paracelsus Aug 21 '16 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.