1

Apparently Windows 10 anniversary update has a new "feature" which forces some executables, such as Diablo 1 (1996), to run as administrator, even though it works fine as non administrator.

The Diablo.exe file's icon now has a UAC shield appearing, and an UAC prompt appears when I run it.

If I rename Diablo.exe to anything else, the UAC shield is gone, there is no UAC prompt when I run it and the game runs fine in a non elevated account.

In the "Compatibility" tab of Diablo.exe, nothing is checked - it's really the name of the file that triggers the UAC prompt.

Well, it's not just the name of the file, as if I rename another executable to Diablo.exe, it doesn't get the UAC prompt.

I cannot find anything on this new "feature". I just know it appeared with the anniversary update (I tried in a VM: no UAC before anniversary update, UAC appears after installing anniversary update). Does anybody know something about it, and how to force an executable to run as invoker?

1

For some applications, Windows automatically sets up compatibility, "knowing" that they wouldn't work without it (even if they maybe do). Compatibility mode, as you know, requires Administrator Privileges, so these apps start as administrator. You will notice something similar in VS2005 on Win 10.

Diablo 1 was probably included in the compatibility list in the new update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.