I'm running Fedora24/KDE5. Every time I accidentally middle click the desktop or drag a file/tab from a text editor onto it I get a "Note" stuck on the desktop.

enter image description here

I can remove it by right clicking the bottom part and choosing "Remove Note". I can disable the middle mouse action in desktop settings (from right click menu). I can't stop them appearing when dragging files (just noticed when dragging a tab from my text editor). I want them completely gone. Is there a package I can uninstall or some option to turn them off?

2 Answers 2

  • Right-click on the desktop
  • 'Configure Desktop'
  • 'Mouse Actions'
  • To the right of the button that says 'Middle-Button' there's a button that says 'Paste' and then some more buttons.
  • Click on the rightmost button that looks like a minus sign,
  • then click on 'OK' or 'Apply'.
  • 3
    Thank you! It is more than a little infuriating that I cannot find these mouse actions through search or through the system settings - terrible discoverability.
    – Job
    Commented Jan 6, 2020 at 8:41

You can remove individual notes by right clicking on the (almost invisible) border around the note and selecting "remove this note"

Right Click Menu

  • No, you can't. No amount of clicking (left or right) gives me any such option.
    – Auspex
    Commented Jun 30, 2018 at 21:26
  • 3
    It worked for me.
    – Pietro
    Commented Sep 25, 2018 at 15:53
  • @Auspex I had the same issue, a long clock in the border area did the trick for me. Commented Jul 7, 2019 at 9:42
  • this is the correct way of removing those notes that "appeared out of nowhere on the desktop" and it seems cannot be removed. KDE should REALLY have a X to wack them.
    – Jobst
    Commented Aug 27, 2019 at 6:39
  • Abysmal UX - really hope they fix this Commented Jan 24, 2021 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .