0

I recently switched from one ISP to Time Warner. Now I often get DNS resolution errors (timeouts) in web browsers and web apps running on any machine connected to my home network. Sometimes a single page refresh resolves (literally) the problem, other times it takes a few tries.

I ran Gibson Research's Domain Name Speed Benchmark and that pretty much confirmed that my ISP's DNS servers are "not reliable." I then used the Benchmark to find the 50 fastest DNS servers available to me. Here's what I did next:

  1. I changed all the DHCP settings on all my machines (many are virtual) on my local network to point to the DNS server located at 198.162.0.5, the static internal IP address of my Windows Server 2012 R2 machine.

  2. The Windows Server 2012 R2 machine's DNS server, on its Properties > Forwarders page, lists 192.168.0.1 (my router) as the only forwarder.

  3. I added 4 of the top 50 DNS servers that the GRC tool produced to the list.

Here's what's happening:

  1. These changes have not resolved the problem. I am still getting timeouts resolving domain names, including really common ones, like Google.com.

  2. Stranger still, after I have problems resolving common names, and refreshing the page eventually resolves the problem, the problem will occur again later. My point being, why isn't my DNS server (running on my server) caching these the responses from the external DNS servers? Even if I screwed up the addition of the 4 DNS servers I added, shouldn't my DNS server at least be caching results?

I turned logging on in the DNS server and I do see that DNS requests from the machines on my network are hitting my Windows Server 2012 R2's DNS server. I also see some of the external DNS servers I added (from the 50 fastest list) are being used to resolve the domain names. And yet, I'm still getting DNS timeouts and previously resolved domain names don't appear to be cached.

  • all resolved records have a time to live so even if cached it will 'die'. why not setting up step two with the forwarders you found so you will have a dns step less? your machines asking you server which asks you router and he asks the dns set up. let your w2k12 dns ask the set up dns's. and you should be able to see the cached records on your server anyway with ipconfig /displaydns. have you tried setup only google's dns servers as forward (8.8.8.8 and 8.8.4.4)? – Zina Aug 22 '16 at 23:19
  • Are you sure the problem is with the remote DNS servers? Is it possible that all DNS lookups leaving your network are being negatively impacted, even if perhaps only some times and not others? – Twisty Impersonator Aug 23 '16 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.