Whenever I download a .dmg, .exe file, etc. Google Chrome assumes I don't know what I am doing and asks me if I understand the risks and warns me that the file may be harmful to my computer. I get the idea, but I want these prompts to stop. How do I do this?


This issue has been brought up a few times, and the answer unfortunately seems to be no. If you know your way around source code, the Chromium project may be of interest. You can hack away at the code and remove the warning.

  • 19
    Wow. The good old "download the source and fix it yourself" solution. Well, I do it myself too but it is certainly not a solution. Maybe one should go for "fork the project" if the upstream is not willing to fix the problem? Out of the frying pan, into the fire :) – Tronic Jun 26 '12 at 19:57
  • There seems to be a way around this now. Download a well-known program like PuTTY (putty.exe) and you get no warning, the download begins right away in Chrome. Maybe it has to do with traffic or page ranking or some level of trust the site has attained. – Matt K Aug 8 '14 at 16:20

The solution without turning off security settings is to to go to Under the Hood, in the Download section, click box next to "Ask where to save each file before downloading".

For those of you who don't know where your normal Download folder is or you are like me that you want a folder on your desktop for easy maintenance, create a new folder on Desktop, and I bet you can't guess what I named it, Download.

Then go to a site and do a search for something that has a PDF document or other downloadable file. Download it. The first time you download this type of file, the normal box pops up at bottom of your browser asking to keep or discard, select keep.

After the file is downloaded and the icon appears for that type of file, click on the little arrow to the right and click on it and in the little menu box select always open this type of file.

  • 5
    yeah, but doesn't this mean that the file gets opened automatically once the download completes? – finiteloop May 1 '12 at 3:55
  • +1 Opens the the PDF reader but you can close it with Alt-F4 (since it will be active) which means you don't have to aim for a moving button with your mouse. – Aaron Digulla Aug 26 '12 at 16:38
  • 2
    Doesn't work for me. Chrome asks me for permission, I click "keep" and my PDF program gets opened immediately. – Nowaker Nov 18 '12 at 2:44
  • For those of you who are trying to download multiple files at once, you may want to add permission for whatever site to download multiple files at once without a prompt, otherwise this solution won't help. – jmac Nov 19 '13 at 6:12

I know this is very counter-intuitive but I just did it and it stopped the exe download warning for me. Enable this option: [Protect you and your device from dangerous sites] Yeah, I know, it doesn't make sense, but enabling it resolved my issue on Chrome v59. I would think the exact opposite would be true but no, this did it.


There IS a way to stop Chrome (or Chromium) from showing this annoying prompt. You have to exit browser, locate Preferences file of your Chrome profile (~/.config/chromium/Default/Preferences in Linux), find 'download' section that looks like:

"download": {
  "directory_upgrade": true,
  "extensions_to_open": "",
  "prompt_for_download": false

and change "extensions_to_open": "", to "extensions_to_open": "pdf", and you won't see that prompt any more :) If there are already other extensions, use a colon to separate pdf from the existing entries (i.e. "foo:bar:pdf"). Then save the configuration file.

Originally found at askubuntu.com, posted by Rinzwind

  • Interesting answer, but maybe for a different question? I don’t see “PDF” mentioned anywhere in this question. – Scott Apr 10 '13 at 22:33
  • @Scott the answer seems to imply that you can specify any file extension, not just PDF – finiteloop Apr 11 '13 at 6:12
  • @Scott, most of the questions about this Chrome security warning are about PDFs, every single one being closed and linking to this thread so I posted it this way. Besides, you can specify any extension, .exe or .dmg as well. – Tomek Sztuk Apr 12 '13 at 6:39
  • 2
    I don't think this proposed solution solves the problem. The use case that triggers this issue for me (and I think most people) is wanting to bulk download PDFs without opening them. Setting extensions_to_open (or equivalently, selecting "Always open files of this type" in the download bar) does circumvent the warning, but pops up a PDF viewer instead. The desire is to get one-click downloads, without a warning and without a viewer. – Reece Jun 3 '13 at 16:19
  • 4
    -1 This does not work for me. Setting extension to open will cause pdfs to auto-open but not before the annoying "This type of file can harm your computer. Do you want to keep <name of file> anyways?" warning. The setting above only sets the auto-open (which can eb done in browser without manually editting config files. Auto-open or auto-save, the utterly annoying prompt always appears. I get it google you want to keep users safe, but this is making me consider another browser. Fine make warning the default option, but ALWAYS provide an override (somewhere). – theUnhandledException Jul 5 '13 at 17:04

If you are in an enterprise environment, there is an ADMX template for Group Policy that has a setting to control the warnings.

The description says that it's only for Domain Joined machines, but the templates typically manage the registry, so it may be that this can be tuned on standalone machines, too.

Group Policy Configuration


What I do is tell chrome to ask me where I want each file to go. I dont get a warning, but I "will" get the file/save dialog. Just go to customize and control - settings - Advanced settings - Tick "Ask where to save each file before downloading" and tell it where your default download folder is.

I have created a large default folder (C:/Temp/Downloads)with other specialized folders within it.You can use.../documents/download or anywhere you choose. Videos go to the video folder (C:/temp/downloads/videos), utilities go to the utilities folder C:/temp/downloads/utilities),texts got to the text folder and programs stay in the download folder. I have made other types also. If it is set up this way, its a simple thing to determine where a download will go and as a plus it wont tell you that a file has the possibility of being a danger to all life on earth......... lol.

I use this method to pre-sort my downloads so it is easier to find the songs from the videos from the programs from the pictures from the etc. Works for me, especially after a night finding all types of stuff that I want to try or see. Works well to create a special you-tube folder too.

Hope this helps.


There is a workaround on Ubuntu for people that are really fed up with this problem by now and do not want to recompile the source code on the other hand. The reasoning is quite simple. Perhaps we do not want Chrome to decide which files to automatically open, but we are better able to do it ourselves.

So, just as Uniblab suggests, tell Chrome to download the file, not open the file. This only means pressing Enter once. Use for example $HOME/setup as download folder.

Then (on Linux) have a script in the background that is notified through inotify.


flags="--format %f"
while true; do
    download=$(inotifywait $flags -e close_write $path)
    if [ "$extension" != "pdf" ]; then
    mime=$(file -b --mime-type "$file")
    if [ "$mime" = "application/pdf" ]; then
        acroread "$file" &

This will automatically open a file if it has MIME type application/pdf, so be careful. You can check for malicious code yourself before you open it using your favorite executable code scanner. To use the script at start-up, edit crontab -e:

@reboot /usr/bin/abovescript

I think this might actually be the proper way to do stuff. It should be the task of a dedicated program (much more complicated then this script) that is allowed to start applications on your computer. Perhaps to allow Chrome to do that is actually a potential security breach.

Of course on Windows you will need to find another tool. On MacOS, you might want to use fswatch which is in homebrew.


Go to Options / Under the hood / Privacy and uncheck "Enable phishing and malware protection".

And voilà, no warnings anymore.

  • 6
    Doesn't that also disable other protections? Honest question, I don't know. – CarlF Jun 23 '11 at 13:07
  • 1
    At least as far as PDFs go, this does nothing to solve the question at hand - PDFs still prompt to be saved or discarded. In fact, it probably does more harm than good by opening your browser session to malware. – NoCatharsis Aug 18 '11 at 14:07
  • 2
    I strongly recommend against this approach. Not worth the risk just to avoid clicking a button when downloading a file. – bradym Jun 30 '12 at 17:18
  • 3
    This option is no longer available in Chrome 59. – KC Wong Jun 19 '17 at 2:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.