25

I was attempting to change file open preferences on Windows 10 today, when I encountered an unexpected behavior.

Normally, when choosing associations, I will be able to select the "Always open with" checkbox as I could previously with older Windows versions since 98. However, when trying to choose image files, the association window did not show the checkbox.

enter image description here

The normal version of this window should look like this:

enter image description here

This question was also asked on Reddit but there was no answer there.

How should I go about changing the default file open program in this case?

6
  • What user group is the user in?
    – Ramhound
    Commented Aug 24, 2016 at 11:26
  • @Ramhound Administrator
    – March Ho
    Commented Aug 24, 2016 at 11:45
  • Is this problem seen only for specific file types?
    – w32sh
    Commented Aug 24, 2016 at 11:57
  • @w32sh As mentioned in the question, only for image files.
    – March Ho
    Commented Aug 24, 2016 at 11:58
  • 1
    MS has been having a lot of trouble deciding what to do and how to be consistent with file type associations (which i believe is related to their fixation on having a fricken appstore... ). see here for some of the uglyness: ghacks.net/2016/02/16/… It actually sounds like they may have disabled the ability to set file type associations on certian types that they want to remain tied to their default apps. Commented Aug 24, 2016 at 12:27

6 Answers 6

6

As of August 2019, the latest version of Windows 10 sets the default application for viewing images in the "Apps" settings.

  1. In the search bar, type "Settings".
  2. Select "Apps" in settings.
  3. In the menu at the left, select "Default apps".
  4. Choose your default photo viewer app.
3
  • As of Feb 2021, you can just type "Default Apps" into the Win 10 search bar instead of doing steps 1 - 3 above.
    – willus
    Commented Feb 19, 2021 at 20:55
  • My default apps has no .jpg extension...
    – aderchox
    Commented Feb 12, 2022 at 6:40
  • Same here on Win11, the ext is missing and I cant add it to set it in the less then desirable UX Commented Jul 13, 2022 at 20:00
1

There is different look (and behaviour) of that dialog for any file type:

Context -> Open With ► -> Choose Default Program…:

Context-OpenWith-ChooseDefaultProgram

or Context -> Properties (General tab) -> Change… button
or (the same) Change program… button in Control Panel\ … \Set Associations:

Context-Properties-GeneralTab-Change

Conclusion: The last dialog is intended to set default program for all files of given extension; therefore, the Always use this app to open … checkbox would be superfluous here.

Please note:

  • Context key is used in above text as an abbreviation for mouse right-clicking i.e. usual request for a context menu which is performed on the keyboard either by clicking the Context key (menu-like looking key usually to the right of the space bar between RightAlt and RightCtrl) or by Shift+F10;
  • images were taken from Windows 8.1 but behaviour keeps unchanged and should apply to Windows 10 as well;
  • (too long to comment; I'll meet your wish if you do call for deleting this answer.)
5
  • 1
    Thanks for the help! However, using the context-properties option did not show the window (Win10 Anniversary).
    – March Ho
    Commented Aug 24, 2016 at 17:55
  • 3
    Yup - this is no longer in windows 10. Both the change button and checkbox are missing for images. Commented Aug 26, 2018 at 13:24
  • 1
    @DannyStaple - If you are implying that "Always open with" checkbox is no longer in Windows 10 then you are mistaken.
    – Ramhound
    Commented Oct 11, 2018 at 19:45
  • @Ramhound The "Always open with" checkbox isn't there in Windows 10 in some cases. I think it happens when it resets to the built-in app like Images. The puppies at MSFT are doing this on purpose, 100%!
    – rustyx
    Commented May 1, 2019 at 12:40
  • Not sure about the checkbox being superfluous. The behavior I experience on some of my machines is 1) opening an unknown filetype via double click, 2) the dialog shows up without a checkbox, 3) an app is selected and the dialog is confirmed - yet no default app is set. I.e. double clicking the same file of unknown type will restart this loop. Also the icon of the file does not change, which would indicate a default app being set. I reproduced this behavior as I type this comment. This is not true for all of my machines though, iirc. Commented May 17, 2021 at 10:48
1

It's not an exact answer to the question, but I was able to re-set the application used for media/image files by using the windows key and searching for "choose default apps" -- this pops up the "choose default apps" app (yes, I know...) and from there you can set what program (VLC, IrfanView, etc) is used for media files...

1
  • 3
    It doesn't work - for some reason, IrFanView will not show as an option here. The microsoft photos app is ugly and useless and not a viable alternative. So annoyed right now. Commented Aug 26, 2018 at 13:21
1

My recent Windows 10 install was also missing the "Always use this app..." checkbox. I got "Always use this app..." back somehow:

enter image description here


I'm not exactly sure how I got it back, but I think it was:

  1. Run Stop Resetting My Apps
  2. Click all the different types (to prevent Windows from resetting)
  3. Click all the different types again (to allow resetting, again)

However, between steps 2 and 3 I tried many other things:

I think one or more of these programs reset a Windows 10 registry flag that enables/disables "Always use this app..."

Background information on why recent versions of Windows 10 are missing ""Always use this app..."

0

The easiest way to solve this problem is to use the "FileTypesMan" free tool, choose the file associations that are producing this problem and right click on "Open File Type in RegEdit", then just DELETE the keys and try using "Open with" again - the "always use this app to open .xxx files" should be restored when you use "Open with" again. Obviously this works with any kind of files!

0

I found a solution to this.

  • Right click on document that you want to assign a default a program to it
  • Click Properties
  • Click Change

Properties image

  • Then choose the program that you want. That's it!
1
  • 4
    This route has been removed too. Commented Aug 26, 2018 at 13:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .