3

VNC viewer unable to login getting error like

"connection failed -End of stream Possible causes: -Another user is already listening on this ID -Bad connection"

when I am trying to access 1024x768 resolution.

can you please provide some more solution for that?

2

I got this error from TigerVNC viewer:

$ vncviewer server.example.com:5991

TigerVNC Viewer 64-bit v1.5.0
Built on: ??-??-?? ??:??
Copyright (C) 1999-2015 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Tue Oct  4 12:54:00 2016
 CConn:       connected to host server.example.com port 5991
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type None(1)
 CConn:       End of stream
$

It turns out that this can mean another client is already connected, and the -shared flag fixes the situation:

$ vncviewer -shared server.example.com:5991

TigerVNC Viewer 64-bit v1.5.0
Built on: ??-??-?? ??:??
Copyright (C) 1999-2015 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.

Tue Oct  4 12:53:43 2016
 CConn:       connected to host server.example.com port 5991
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type None(1)
 X11PixelBuffer: Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using Tight encoding
| improve this answer | |
1

My problem was because I put the wrong IP.

I needed to use -L 5901:localhost:5901 instead of -L 5901:publicIp:5901.

start "" "%ProgramFiles(x86)%\KiTTY\kitty.exe" -ssh publicIp -l username -pw password -L 5901:localhost:5901
| improve this answer | |
0

You could solve this if you restart xinetd service

First stop the xinetd service

   # /etc/init.d/xinetd stop

Next start the xinetd service

   # /etc/init.d/xinetd start
| improve this answer | |
-1

My situation - no admin rights on server, UltraVNC Viewer as client (shared flag had no effect for me).

On server side I ran

vncserver 

from the terminal window.

This created a new instance with higher port number, I edited my tunnel accordingly and was able to connect. Of course the session is brand new.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.