6

I have a laptop running Debian Jessie with Intel Wireless-N 7265 BGN adapter. Mine looks like the one on the right, with an antenna cable going to the right-most socket.

According to dmesg I'm using WLAN firmware iwlwifi-7265-16.ucode and BT firmware ibt-hw-37.8.10-fw-1.10.2.27.d.bseq, which I have installed from Jessie-backports. As far as I understand, Wifi / Bluetooth coexistence is possible and enabled:

$ sudo modinfo iwlwifi
...
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
...
$ cat /sys/module/iwlwifi/parameters/bt_coex_active 
Y

Both Wifi and Bluetooth work separately, however, when I try to activate them at the same time, I lose Wifi connectivity. The laptop disconnects from a network if it was connected, and scanning for networks yields no results unless I disable Bluetooth. Once Bluetooth is disabled, I'm able to reconnect to Wifi again.

What could be the reason for this? Is there a particular firmware I could use to get Wifi and Bluetooth work together? Or do I have the bad kind of adaptor, and upgrading it would solve my issue? Would it help to get a second antenna connected? I don't have one, but I would consider ordering / making one if that is known to help.

EDIT: Here's what happens on my system starting from a fresh reboot:

dmesg | grep iwlwifi > dmesg_iwlwifi

dmesg | grep -i blue > dmesg_bluetooth

sudo modinfo iwlwifi | grep -v alias > modinfo_iwlwifi

sudo modinfo btintel > modinfo_btintel

uname -a

Linux hostname 4.6.0-0.bpo.1-686-pae #1 SMP Debian 4.6.4-1~bpo8+1 (2016-08-11) i686 GNU/Linux

and here's what happens when I connect a BT device while using WiFi: btmon, udevadm, iwevent, dmesg.

EDIT2: Things I have tried.

  1. setting cfg80211_disable_40mhz_24ghz to "Y" - no visible changes
  2. setting bt_coex_active to "N" - make things worse: WiFi stops working altogether, BT still works fine
  3. upgrading firmware to the latest version as described here - no visible changes
  4. setting disable_11ac to "Y" and 11n_disable to 1 - no visible changes

Final edit: we went to see some friends this weekend, and when I wanted to show them my issue, I discovered that I could stay connected to their router while using BT. There is a drop in connection speed when BT is in use, but this is to be expected AFAIK. I'm not sure if my question will be of any use to anyone, but just in case: the router I had the issue with was a german FritzBox configured to 2.4 GHz, channel 6. Since I don't own that router, I can't really fiddle with it to investigate.

12
  • 1
    try this answer.
    – harrymc
    Aug 30 '16 at 15:43
  • Nice find, going to test it and report back. So, disabling BT coexistance in settings actually improves coexistance? I love Intel! Aug 30 '16 at 16:00
  • 1
    @DmitryGrigoryev The coexistence scheme is supposed to cause the two transmitters to cooperate and avoid stepping on each other. But instead what happens is the bluetooth transmitter says it always wants to transmit (because it's not smart enough to do otherwise) and so the Wifi transmitter never gets to. Aug 30 '16 at 19:59
  • @DavidSchwartz What you say make sense. Unfortunately, I observe the opposite effect: disabling coexistance seems to kill WiFi entirely. I wonder if I have a hardware problem. Aug 30 '16 at 20:15
  • 1
    I'm starting to think that the Debian drivers are just programmed plain wrong, and this even looks like a general Linux problem. The only advice I can see is to make an effort to switch to 5Ghz if you can and update every firmware possible. Or switch to Windows where the drivers work correctly.
    – harrymc
    Sep 1 '16 at 17:17
2
+50

This isn't an answer per se, as there is insufficient information provided in the question for me to provide a resolution, but a comment requesting this information would be difficult to follow.

Are you connecting to a wireless router on the 2.4 or 5 GHz bands? If you are typically using 2.4, does your router support dual band 'N'? If so, try configuring the router for 5 GHz, connecting to that, and seeing if the bluetooth behavior changes. The 2.4 GHz Wifi band and bluetooth spectrums have a great deal of overlap and can conflict with each other - this is an attempt to see if that is at play here.

If there is no change with that test, or you don't have a router that would allow you to try it, the next step is to collect more information on what is happening.

Please provide the output from the following commands. The dmesg commands should be run shortly after boot so that the relevant entries aren't rotated out.

sudo modinfo iwlwifi | grep -v 'alias'
sudo modinfo btintel
dmesg | grep iwlwifi
dmesg | grep -i blue
uname -a

Start the next steps in the 'working' configuration of wifi connected and bluetooth disabled.

1. Open three terminals as root and a fourth as a regular user.

2. In one root terminal run the command

btmon 

3. In the 2nd root terminal run the command

iwevent

4. In the 3rd root terminal run the command:

udevadm monitor

5. Finally, in the non-root terminal, run:

dmesg -w

6. Now with these monitoring tools running, try to simultaneously utilize wifi and bluetooth using more or less the same sequence of steps you described above.

  1. Start with bluetooth disabled and wifi connected
  2. Enable bluetooth
  3. Presumably wifi will have disconnected; if so try scanning for a network so we can see what the logs report.
  4. Try to connect to a bluetooth device
  5. If connected to a bluetooth device, now try connecting to wifi again.
  6. Disable bluetooth, and reconnect to wifi.

The output of these logs should allow us to debug what is happening here. You may want to obfuscate MAC addresses in the results, although please leave them uniquely identifiable.

Post the results on a website like pastebin, as some of them may be lengthy.

2
  • Unfortunately, I cannot modify router settings to switch it to 5GHz. I have added logs to my question (note that WIFI disconnect happens when I connect a BT device, not when I enable BT interface). I hope I have caught something useful. Aug 30 '16 at 6:57
  • I could confirm that the issue is in the router rather than the laptop. I'm accepting your answer because it provides a good starting point for people who will have to investigate similar issues. Sep 5 '16 at 8:52
2

Bluetooth and 2,4 GHz Wi-Fi are working on the same bandwidth: 2400 MHz - 2483 MHz. Bluetooth is switching channel regularly, when 802.11b,g,n & ac are using a fixed channel. They can coexist up to the era of the 802.11n, if the Wi-Fi channel is configured to use a standard channel width which is of 22MHz. If not specifically documented they won't coexist if Wi-Fi is configured on double width channel (44 MHz).

To test for this, use:

• Disable 40MHz on 2.4GHz: cfg80211_disable_40mhz_24ghz module parameter

0
2

I faced the same problem. I have the same Intel 7265 card. Though of course parameters of both router and wireless card matter, the below kernel module parameters worked for me. Note that both are required, either one of them alone will not work.

  1. Save the below in /etc/modprobe.d/iwlwifi.conf

    options iwlwifi 11n_disable=8 bt_coex_active=0

  2. Run the following commands

    modprobe -r iwlmvm || modprobe -r iwlwifi || modprobe iwlwifi

5
  • Do you know what is the difference between 11n_disable=1 which I have tried and 11n_disable=8 which you suggest? Sep 20 '16 at 8:41
  • @DmitryGrigoryev Value of 1 means "full" mode. Value of 8 means "enable agg TX". Run modinfo -p iwlwifi and it will list all parameters and their values. Sep 20 '16 at 11:33
  • Ok, and how do I know I need this "enable agg TX" option? How is it related to bluetooth? Sep 20 '16 at 11:38
  • 1
    I'm not sure on the internal implementation of the driver and what it does. This i found purely by experimentation. I can surmise though that it probably makes wifi transmission more aggressive and that somehow solves the problem. Sep 20 '16 at 11:52
  • On newer intel devices the default bt_coex_active setting is supposed to work better so it's still worth experimenting with leaving bt_coex_active alone and using the other settings. They all alter the balance of reliability vs speed, and wifi vs bluetooth, when both are using the 2.4GHz band at the same time The defaults tend to favor reliability, and wifi over bluetooth speed. The default bt_coex_active=1 is supposed to handle this intelligently but doesn't work as well for some cards and sometimes you might want to alter the balance between wifi and bluetooth. Sep 4 '20 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.