-2

I have this portable virtual box i have in my USB.

enter image description here

As you can see on the above image it is called Portable-VirtualBox.exe(That directory is in my USB) . And if you look closely you can see an admin image, that tells you have to run it via admin . (bottom right of icon of Application). Well how do I delete that, so anyone can run that application? And I want it to stay like that in any computer (so I don't have to run via admin). Help would be appreciated.

**Note : **
I'm trying to do this on a school-provided computer, so I cant access Control Panel, nor can I use Command prompt; and, of course, I don't have administrative rights. The purpose for which I intend to use VirtualBox is to run osDev in a VM in order to develop a kernel.

1
  • There isn't much that can be done to an application as the end user, if it requires elevated persmissions to run, if that is required or not is determined by the program itself and its manifest file. Even if you change the manifest file, if the program requires the elevated permissions to function, if you don't eslate the process the application simply won't function correctly.
    – Ramhound
    Aug 25, 2016 at 13:48

2 Answers 2

2

Depends on the application. If you set it to "always start as admin" yourself then you can undo this in the compatibility tab of the properties windows of the file.

If you didn't do that then there is a big chance that the developer of the application "told" its application it requires admin privileges.

If you are actually an admin and just are frustrated by the pop ups asking if you really are sure then you could disable UAC http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/

5
  • Im trying to do this in a school computer, so i cant go to control panel at all lol.. cant even go to terminal. And if you ask why, well i do osDev and i want to osdev in my programming classes.
    – amanuel2
    Aug 25, 2016 at 13:18
  • What i used to do when i was in school was set up an RDP connection to my PC at home. ofc hoping they allow port 3389. if they dont you could try setting up a RDGateway which will connect over port 443 which is unlikely to be blocked. if all else fails perhaps teamviewer, not 100% sure if it requires admin privs
    – Kage
    Aug 25, 2016 at 13:21
  • Im testing teamviewer right now. thanks for that suggestion!
    – amanuel2
    Aug 25, 2016 at 13:27
  • Kage : seems like i can connect to my dads computer via teamviewer, hope i can do same there at school . But can i make it fullscreen?
    – amanuel2
    Aug 25, 2016 at 13:41
  • When you have a teamviewer connection open, there is a bar with options, in the bottom left corner there is a small icon to go fullscreen
    – Kage
    Aug 25, 2016 at 14:09
-1

Right click your executable, go to the compatibility tab, and there should be an option Run this program as an administrator.

13
  • Yes , but that is not what i want... at all " Im trying to do this in a school computer, so i cant go to control panel at all lol.. cant even go to terminal. And if you ask why, well i do osDev and i want to osdev in my programming classes"
    – amanuel2
    Aug 25, 2016 at 13:20
  • Ask permission from your System administrator and try to get access that way. Aug 25, 2016 at 13:23
  • That will never happen. "Ask Permission", to osdev? Haha :D
    – amanuel2
    Aug 25, 2016 at 13:27
  • No, you said it's on school PC's, if you really want to use a certain application, ask your school system admin for permission. Aug 25, 2016 at 13:31
  • Can you stop telling me that @JustDenDimi ? Im never gonna do that, and i already told you so . I dont ask for Adminstrator Priv. and even if i do , they would say no. Schools dont care about programming these days so, it would be a guarrante they will say no
    – amanuel2
    Aug 25, 2016 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.