2

I have a Dell XPS 13 (9350) running Windows 10 and I can't seem to disable the automatic brightness changing depending on what's on the screen. If the screen is primarily light the brightness will go up, and when it's primarily dark it'll dim. I'm having the same issue as outlined in these posts:

but none of the solutions given worked for me. In my Intel HD Graphics control panel there is no "Display Power Saving Technology" option, nor are there "On Battery" or "Plugged In" tabs in the power section. This problem persists on both battery and AC.

I am willing to reinstall drivers but I am not willing to reinstall Windows. I am also familiar with the command prompt and registry editor.

Thanks for any and all help!

1
2

1.Go to Control Panel > Hardware and Sound > Power Options, then click on "Change plan settings" next to your active power plan.

2.Click on "Change advanced power settings."

3.Scroll down to Display, then under Enable adaptive brightness, switch it off for both the battery and plugged in modes.

1
  • This setting has been off from the start and I even tried turning it on and off again. No luck. – katacarbix Aug 26 '16 at 21:47
1

For me I had to disable it by right-clicking on the desktop and choosing "Intel(R) Graphics Control Panel" (it's only accessible from the desktop, not the Start Menu). "Power", "Display Power Saving Technology", "Disable". Hope that helps someone.

2
  • The OP specifically mentions an inability to access this setting in their question. I don't know whether they added that part after receiving your answer, but it doesn't look like it (no edits of the question showing for me). So the fact that your answer has gotten two upvotes within 1 1/2 months astounds me. – Kenny83 Dec 9 '20 at 20:34
  • It's not very obvious where the Intel Graphics Control Panel lives. I never would have thought to look on the desktop's context menu if it didn't appear in the Start Menu. And this page is the first Google result for this issue. So even if it doesn't help the OP, it apparently helped someone. – baochan Jan 29 at 22:07
0

On Desktop PC, Nvidia gtx 1060, after a full day of trying to change the windows 10 power settings and after searching for registry solution on the net to stop changes in brightness depending on the screen contents and after a full day trying to solve this anti-usability "feature" , poor PC display stability due to this stupid auto-brightness, auto-dynamic-contrast , Adaptive Brightness persisted. lost a full day with settings, registry tweaking and so on hoping to solve this issue and to disable Adaptive Brightness, Adaptive Contrast .

Solved for me: In the end, for me worked this https://community.adobe.com/t5/illustrator/auto-brightness-dimming-in-apps/td-p/9487179?page=1 by Gregbike: unistall the poor quality software MSI X Boost App, and the display becomes stable.

-1

1.Change advanced power settings 2.ATI Graphics Power Settings, ATI Powerplay settings 3.Change On battery > Maximize Battery Life to Maximize Performance.

Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.