1

I don't know what changed (or if this is just a fluke with Google Talk at the moment), but my Google Talk buddies aren't appearing online in Pidgin even though they are. I tried deleting the account and adding it again, but to no avail. I can still talk to them, though (if they start the conversation).

Any idea what's happening / how to fix?

2

Please make sure that you have actually configured the Pidgin messenger to work with GoogleTalk.

I assume you are using a lunux machine.

Follow the instructions here or here

If it still fails you can always use Gtalk.exe with wine,It works like a charm :)

PS:Commonly the problem you stated occurs when something happens to the TLS/SSL settings in the network.

  • Actually I'm using Windows XP. – Nathaniel Feb 22 '10 at 5:41
1

When I started using jabber.el in emacs as my chat client I noticed that it was not grabbing my gmail contacts the way that pidgen used to, but I could fix that by subscribing to their presence data manually inside jabber.el. I think a similar option should be available in pidgen (though of course full integration with your gmail contact list would be better, especially if you have more than 10 or 20 contacts).

0

Bingo. It has to do with them being in my Gmail chat list. I'm signed into another Gmail account with Opera. I added that account to always be shown in my chat list, started Pidgin up again, and voilà! there it was. Yay for making me think.

Anybody have any technical insight into how this works, like what the protocol behind that setting is?

  • The jabber protocol involves subscribing to a presence (which means you request push information about their log off / log on / status change). The protocol is called xmpp (extensible message presence protocol) and is well documented on wikipedia en.wikipedia.org/wiki/… – Justin Smith Feb 22 '10 at 7:13
  • @Nathaniel, can you explain clearly your fix for this? I know someone who is experiencing the same exact issue under Windows, like you. – user84207 Nov 1 '13 at 6:01
0

Since it was never really spelled out, I just fixed this problem for one contact by: * Right-clicking their name in my contact list and choosing "Cancel Presence Notification" * Right-clicking their name again and choosing "(Re-)Request Authorization"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.