7

I am unable to update my display resolution of Centos7 which was installed in the Hyper-v of Windows 8.1.

Earlier I have faced the same problem in VirtualBox but it was resolved after installing VirtualBox Guest Additions.

In hyper-v, after installing the Linux integration tools I can't use the mouse it and some other problem also happened. Can you give me any idea to get rid of this. I have tried to use the following commands

grubby --update-kernel=ALL --args="video=hyperv_fb:1280x1024"
sudo grubby --update-kernel=ALL --args="video=hyperv_fb:1280x1024"
system-config-display --reconfig --set-resolution=1920x1200

but nothing helped me.

1
  • I tried the same commands many times and reboot each time. I can confirm grub is correctly configured with right argument by typing 'E' at startup and checking manually the startup script. But the size of the screen remains stuck to 1024x768
    – Antwane
    Jun 18, 2017 at 17:16

1 Answer 1

16
+50

There is a known problem with VMs on Hyper-V unable to set the screen to a high resolution, with no way of changing it either from KDE System Settings or Hyper-V virtual machine properties.

The problem is with the frame buffer driver of Hyper-V. CentOS provides a tool called grubby for managing grub.cfg which is much easier to work with than editing /etc/default/grub and running update-grub.

To set the desired screen resolution under Hyper-V, open a terminal and execute:

sudo grubby --update-kernel=ALL --args="video=hyperv_fb:2560x1440"

then reboot. Replace 2560x1440 with the desired screen resolution.

If you find that you are still unable under Hyper-V to reach the desired resolution, the other solution is to install xrdp and use remote desktop. See the article Install xrdp on CentOS 7 / RHEL 7.

9
  • I finally reinstalled the system in a fresh VM, and re-applying the grubby command. I noticed that it worked only for a few screen resolution, but it worked. I still don't know why this was not possible in my previous VM, but anyway I can now work with this system. Thanks
    – Antwane
    Jun 19, 2017 at 9:09
  • Have you installed the Hyper-V Linux Integration Services as explained here?
    – harrymc
    Jun 19, 2017 at 9:56
  • Actually, I tried to change the display resolution of a VM under Fedora. I read in many places that the video=hyperv_fb is the right way to look, so I decided to re-open this question because the problem and the solution might be identical to RHL/CentOS. Unfortunately, Hyper-V Linux Integration doesn't support Fedora (I just tried)
    – Antwane
    Jun 19, 2017 at 10:02
  • Latest Fedora is supposed to natively support Hyper-V Linux Integration Services. Apparently theory doesn't match practice, or the integration is limited to only some screen resolutions.
    – harrymc
    Jun 19, 2017 at 10:57
  • 1
    @SaeedBaig: Thanks, it should have been sudo to start with. Fixed.
    – harrymc
    May 1, 2021 at 13:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .