0

I have a 1.5TB external drive (Seagate FreeAgent GoFlex USB 3.0) that's been encountering some issues with my new computer setup.

For several years, I had an ancient Dell laptop running 24/7 to serve files from this drive-- and it worked perfectly. I recently bought a new laptop for myself, so I bid farewell to the Dell and upgraded my server computer to a much quicker HP laptop (quad-core i7, 8GB, dedicated GPU, etc.) I plugged in the external HDD to the HP and set up a Plex server, some SMB shared folders, and an iTunes home sharing server that all direct to media on the drive.

The drive will work normally for a few hours, then ostensibly ejects and remounts itself. Upon doing this, Autoplay pops up and the drive will show up in Windows Explorer, but for all purposes is unusable:

Z:\Music is not accessible. The device is not ready.

I have restarted the computer many times, checked drivers, even changed the drive letters around (the drive's 2 partitions are now mounted as Z: and Y:). I've tried all 4 USB ports as well. The drive partitions are both NTFS and the disk is using a GPT partitioning scheme. I can't even safely remove the disk, as I get hit with this:

Windows is unable to stop the device 'USB Mass Storage Device'.

The only real differences between this computer and the Dell are the operating system and presence of a USB 3.0 chipset. The old computer ran Win7 Pro and connected to the drive via USB 2.0, and the new computer runs Win10 Enterprise (w/ Anniversary Update) and can utilize the USB 3.0 connection.

Plugging the drive into my newer laptop (Win10 but w/o the Anniversary Update), I encounter no problems and the drive reports a healthy status on both computers. I even backed up ~60GB to the drive without issue. A 128GB flash drive connected to the HP doesn't have any of these problems, so I think the ports are all fine.

It's quite annoying to have to unplug and reconnect the drive every few hours if I want to use it, which defeats the whole purpose of an always-on server. I suspect the OS or drivers, but any other suggestions are welcome. It seems others are having similar issues with this external drive in Win10, too:

External HDD unrecognized in Win10 but works fine in Win8.1

Thanks, E-swizz

  • Have you tried uninstalling your Drivers for USB??? – Luciferangel Aug 28 '16 at 12:42
  • @Luciferangel I unplugged all USB devices from the computer, uninstalled all USB drivers, and restarted the computer. The HDD worked fine for a little while and then the same problem occurred. It seems to me that the the drive is automatically spinning down after periods of inactivity, and then it's unable to initialize again. – E-swizz Aug 28 '16 at 19:48
  • You might wanna go check your power options for USB selective suspend – Luciferangel Aug 28 '16 at 22:22
  • Disabled USB Selective Suspend and restarted... still no luck. – E-swizz Aug 29 '16 at 7:03
0

I recently started having this problem too. I think its the power saving mode that lets the hard drive power down. Here is the fix. Go to control panel/power options/change plan settings/change advanced power settings/USB settings /USB selective suspend setting The set the plugged in option to disabled. Hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.