0

I am working on virtual machine on Ubuntu and trying to install software using following command: sudo apt-get install, but when I type the same on a terminal in the guest OS I get following: sudo aptBget install.

Which means - is not going to be printed here. It seems ther is keyboard setting issue for VM. May i know how can i fixed this?

1

As a workaround for this particular command, in recent versions of Ubuntu you can use apt instead of apt-get:

sudo apt install

It's not clear why the hyphen is not printed as it should, because there's not enough details in the question. Please provide as much details as possible about the nature of the issue: like if it's a display-only issue, or the hyphen is not actually sent from the keyboard, and whether it works in other applications within guest OS or not. In case if it's really related to the VM, then please provide details about the VM setup, software versions of host and guest, their options, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.