0

I am setting up a Poweredge T110 to migrate a website from the VPS it is currently hosted on to run in Fedora Server 24 inside ESXi 6. I have followed this tutorial, on both the VPS which runs Fedora Server 24 as well, and the new virtual server on my T110.

I can access the default server block and get the test page to show up properly, however the new server block that I created following the pattern of the tutorial exactly, does not work. I receive a time out when trying to access the web page from the address test.foo.org.

I have already opened port 80 on the system firewall, and in my pfSense router, I have created a NAT rule to forward port 80 traffic at the WAN address to the virtual server's port 80. Canyouseeme.org also backs this up, and shows that I do in fact have port 80 open and it can see the server. I have tried restarting nginx, the server, and changing internal IP addresses. I have also tried putting together this configuration on another virtual machine to no avail. There are no entries in the log relating to the site either. I have checked to ensure that SELinux is not the issue as well.

The configuration for this particular site is as follows. The nginx config unchanged with the exception of the addition of an include for this file, and adding server_names_hash_bucket_size 64;.

server {
  listen       80;
  server_name  test.foo.org foo.org www.foo.org;
  location / {
    root   /var/www/foo.org/public_html;
    index  index.html index.htm;
    try_files $uri $uri/ =404;
    }    error_page   500 502 503 504  /50x.html;
  location = /50x.html {
    root   html;
  }
}
7
  • Please post your nginx configuration file/block. My firtt guess will be SELinux, try switching to Permissive mode (setenforce 0), and see if it help.
    – Rabin
    Aug 29, 2016 at 23:12
  • @Rabin I added the config. Also, I have already tested to see if SELinux was the issue and it is not.
    – Thrakerzad
    Aug 30, 2016 at 2:50
  • Is the host name resolve to the correct IP ?
    – Rabin
    Aug 30, 2016 at 9:23
  • @Rabin, yes. I just checked my nameserver, and I ran a dig search for the domain and both provide the correct IP address.
    – Thrakerzad
    Aug 30, 2016 at 19:13
  • just to make sure that the traffic is actually arrive to the host please run tcpdump -ni eth0 "tcp port 80" on the webserver and see if anything show up by trying to access the web server with the browser.
    – Rabin
    Aug 31, 2016 at 6:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.