2

I tried installing the USB game controller for the Playstation 2 version of the quiz-game "Buzz!" on my Windows 10 computer. While this (pretty simple) controller works well on Linux and (as far as I can remember) on older Windows versions.

Unfortunately, when I plug the controller in, the driver Windows automatically installs has the status "Driver error" in Settings/Connected devices. The driver it installs is called "Logitech Buzz(tm) Controller V1". Searching for this driver name didn't bring up anything useful for me.

In the device manager it shows a "Standard USB Hub" with an error: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)".

My wish is, that the controller gets recognized as a gamepad or generic hid-controller so I can use the input data. I wouldn't mind translating the byte-input myself.

3
  • 1
    Looks like a common problem with Windows 7 also
    – Ramhound
    Commented Aug 30, 2016 at 14:52
  • 1
    Wireshark can now analyze USB traffic on at least some types of hubs. You might want to give that a shot to see what's going on here.
    – bwDraco
    Commented Aug 30, 2016 at 14:52
  • @bwDraco I didn't need it in the end, but that seems to be a cool tool to check out. Thanks!
    – pfirpfel
    Commented Aug 30, 2016 at 15:05

1 Answer 1

8

Found a solution shortly after posting the question:

In the device manager select the broken "Standard USB Hub" and open the properties for it. Select "Update Driver", "Browse my computer for driver software", "Let me pick from a list of device drivers on my computer". There select "USB Input Device" and click OK.

The device "Logitech Buzz(tm) Controller V1" installs now properly and is usable.

4
  • 1
    Tipp works for Windows 7 Pro 32bit as well
    – 576i
    Commented Feb 12, 2017 at 16:25
  • 1
    I needed to change "HID-compliant game controller" to "HID-compliant device" Commented Sep 2, 2018 at 19:52
  • 1
    Thanks, worked perfectly for me!
    – cupiqi09
    Commented Jan 3, 2021 at 21:04
  • 1
    Thanks, it works on Windows 11 too ;) Commented Oct 18, 2022 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .